您的位置:首页 > 其它

hdu 4081 Qin Shi Huang's National Road System(最小生成树变形)

2016-03-03 18:26 375 查看
Qin Shi Huang's National Road System

Problem Description

During the Warring States Period of ancient China(476 BC to 221 BC), there were seven kingdoms in China ---- they were Qi, Chu, Yan, Han, Zhao, Wei and Qin. Ying Zheng was the king of the kingdom Qin. Through 9 years of wars, he finally conquered all six other
kingdoms and became the first emperor of a unified China in 221 BC. That was Qin dynasty ---- the first imperial dynasty of China(not to be confused with the Qing Dynasty, the last dynasty of China). So Ying Zheng named himself "Qin Shi Huang" because "Shi
Huang" means "the first emperor" in Chinese.

Qin Shi Huang undertook gigantic projects, including the first version of the Great Wall of China, the now famous city-sized mausoleum guarded by a life-sized Terracotta Army, and a massive national road system. There is a story about the road system:

There were n cities in China and Qin Shi Huang wanted them all be connected by n-1 roads, in order that he could go to every city from the capital city Xianyang.

Although Qin Shi Huang was a tyrant, he wanted the total length of all roads to be minimum,so that the road system may not cost too many people's life. A daoshi (some kind of monk) named Xu Fu told Qin Shi Huang that he could build a road by magic and that
magic road would cost no money and no labor. But Xu Fu could only build ONE magic road for Qin Shi Huang. So Qin Shi Huang had to decide where to build the magic road. Qin Shi Huang wanted the total length of all none magic roads to be as small as possible,
but Xu Fu wanted the magic road to benefit as many people as possible ---- So Qin Shi Huang decided that the value of A/B (the ratio of A to B) must be the maximum, which A is the total population of the two cites connected by the magic road, and B is the
total length of none magic roads.

Would you help Qin Shi Huang?

A city can be considered as a point, and a road can be considered as a line segment connecting two points.

Input

The first line contains an integer t meaning that there are t test cases(t <= 10).

For each test case:

The first line is an integer n meaning that there are n cities(2 < n <= 1000).

Then n lines follow. Each line contains three integers X, Y and P ( 0 <= X, Y <= 1000, 0 < P < 100000). (X, Y) is the coordinate of a city and P is the population of that city.

It is guaranteed that each city has a distinct location.

Output

For each test case, print a line indicating the above mentioned maximum ratio A/B. The result should be rounded to 2 digits after decimal point.

Sample Input

2

4

1 1 20

1 2 30

200 2 80

200 1 100

3

1 1 20

1 2 30

2 2 40

Sample Output

65.00

70.00

Source

2011 Asia Beijing Regional Contest

Recommend

lcy | We have carefully selected several similar problems for you: 4085 4082 4090 4087 4083

思路:先求出最小生成树

枚举ij两个点(i!=j)造路

if(used[i][j])

rate=max(rate,(p[i]+p[j])/(cost-G[i][j]));

else rate=max(rate,(p[i]+p[j])/(cost-path[i][j]));

G为图

path[i][j]记录生成树上,i到j边长最长值,n个点联通需要n-1条边,我们在生成树的基础上又造了一条路,所以就构成了环,我们去掉环上边长最长的,使A不变的情况下B尽可能的小
#include<cstdio>
#include<cmath>
#include<algorithm>
#include<cstring>
using namespace std;
const int N=1005;
const int inf=2147483647;
double G

,path

,dist
,cost,x
,y
,p
;
int vis
,used

,n,pre
;
double getdist(int i,int j)
{
return sqrt((x[i]-x[j])*(x[i]-x[j])+(y[i]-y[j])*(y[i]-y[j]));
}
void prim()
{
int u,j,i;
double mind;
memset(vis,0,sizeof(vis));
memset(used,0,sizeof(used));
memset(path,0,sizeof(path));
cost=0;
vis[1]=1;
for(i=1;i<=n;i++)
{
dist[i]=G[1][i];
pre[i]=1;
}
for(i=1;i<n;i++)
{
mind=inf;
u=0;
for(j=1;j<=n;j++)
{
if(!vis[j]&&dist[j]<mind)
{
mind=dist[j];
u=j;
}
}
cost+=mind;
vis[u]=1;
used[u][pre[u]]=used[pre[u]][u]=1;
for(j=1;j<=n;j++)
{
if(vis[j]&&j!=u)
path[u][j]=path[j][u]=max(path[j][pre[u]],mind);
if(!vis[j]&&G[j][u]<dist[j])
{
dist[j]=G[j][u];
pre[j]=u;
}
}
}
}
int main()
{
int T;
double rate;
scanf("%d",&T);
while(T--)
{
memset(G,0,sizeof(G));
scanf("%d",&n);
for(int i=1;i<=n;++i)
scanf("%lf%lf%lf",&x[i],&y[i],&p[i]);
for(int i=1;i<=n;i++)
for(int j=i+1;j<=n;j++)
G[i][j]=G[j][i]=getdist(i,j);
prim();
rate=-1;
for(int i=1;i<=n;i++)
{
for(int j=1;j<=n;j++)
{
if(i==j) continue;
if(used[i][j])
rate=max(rate,(p[i]+p[j])/(cost-G[i][j]));
else rate=max(rate,(p[i]+p[j])/(cost-path[i][j]));
}
}
printf("%.2lf\n",rate);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: