您的位置:首页 > 其它

PAT (Advanced Level) Practise 1004 Counting Leaves (30)

2016-03-02 19:38 323 查看


1004. Counting Leaves (30)

时间限制

400 ms

内存限制

65536 kB

代码长度限制

16000 B

判题程序

Standard

作者

CHEN, Yue

A family hierarchy is usually presented by a pedigree tree. Your job is to count those family members who have no child.

Input

Each input file contains one test case. Each case starts with a line containing 0 < N < 100, the number of nodes in a tree, and M (< N), the number of non-leaf nodes. Then M lines follow, each in the format:
ID K ID[1] ID[2] ... ID[K]

where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID's of its children. For the sake of simplicity, let us fix the root ID to be 01.

Output

For each test case, you are supposed to count those family members who have no child for every seniority level starting from the root. The numbers must be printed in a line, separated by a space, and there must be no extra space at the end
of each line.

The sample case represents a tree with only 2 nodes, where 01 is the root and 02 is its only child. Hence on the root 01 level, there is 0 leaf node; and on the next level, there is 1 leaf node. Then we should output "0 1" in a line.
Sample Input
2 1
01 1 02

Sample Output

0 1

用vector把树存下来,然后dfs一遍就好了,没什么难度。

#include<cstdio>
#include<cstring>
#include<vector>
#include<algorithm>
using namespace std;
const int maxn=1e2+10;
int n,m,k,x,f[maxn],deep,y;
vector<int> t[maxn];

void dfs(int x,int dep)
{
deep=max(deep,dep);
if (!t[x].size()) f[dep]++;
for (int i=0;i<t[x].size();i++)
{
dfs(t[x][i],dep+1);
}
}

int main()
{
scanf("%d%d",&n,&m);
while (m--)
{
scanf("%d%d",&x,&k);
while (k--)
{
scanf("%d",&y);
t[x].push_back(y);
}
}
dfs(1,0);
for (int i=0;i<=deep;i++) printf("%s%d",i?" ":"",f[i]);
printf("\n");
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  PAT