您的位置:首页 > 其它

1060. Are They Equal (25)

2016-03-02 16:28 190 查看


1060. Are They Equal (25)

时间限制

50 ms

内存限制

65536 kB

代码长度限制

16000 B

判题程序

Standard

作者

CHEN, Yue

If a machine can save only 3 significant digits, the float numbers 12300 and 12358.9 are considered equal since they are both saved as 0.123*105 with simple chopping. Now given the number of significant digits on a machine and
two float numbers, you are supposed to tell if they are treated equal in that machine.

Input Specification:

Each input file contains one test case which gives three numbers N, A and B, where N (<100) is the number of significant digits, and A and B are the two float numbers to be compared. Each float number is non-negative, no greater than 10100,
and that its total digit number is less than 100.

Output Specification:

For each test case, print in a line "YES" if the two numbers are treated equal, and then the number in the standard form "0.d1...dN*10^k" (d1>0 unless the number
is 0); or "NO" if they are not treated equal, and then the two numbers in their standard form. All the terms must be separated by a space, with no extra space at the end of a line.

Note: Simple chopping is assumed without rounding.
Sample Input 1:
3 12300 12358.9

Sample Output 1:
YES 0.123*10^5

Sample Input 2:
3 120 128

Sample Output 2:
NO 0.120*10^3 0.128*10^3

#include <iostream>
#include <string>
#include <cstdio>
#include <vector>
#include <queue>
#include <algorithm>
#include <stack>
using namespace std;
void modity(string *s)
{
for(int i=0; i<(*s).size(); ++i)
{
if((*s)[i]!='0')
break;
else
{
(*s).erase((*s).begin()+i);
i--;
}
}
if((*s).size()==0||(*s)[0]=='.')
*s = "0"+(*s);
bool flag = false;
for(int i=0; i<(*s).size(); ++i)
{
if((*s)[i]!='0'&&(*s)[i]!='.')
{
flag = true;
break;
}
}
if(!flag)
(*s)="0";
}
void solution(string *a,int *exponentA,int n)
{
int found = (*a).find('.',0);
if(found==string::npos) //小数点不存在构造小数点 1230089
{
if((*a)[0]!='0')//排除0的情况
{
*exponentA = (*a).size();
}
(*a) = "0."+(*a);
}
else
{
if(found==1&&(*a)[0]=='0')//形如 0.1230089
{
for(int i=found+1; i<(*a).size(); ++i)
{
if((*a)[i]!='0')
break;
else
{
(*a).erase((*a).begin()+i);
i--;
(*exponentA)--;
}
}
}
else
{

*exponentA = found;
(*a).erase((*a).begin()+found);
(*a)= "0."+(*a);
}
}
if((*a).size()<n+2)
{
int len = (*a).size();
for(int i=0; i<n+2-len; ++i)
{
(*a)=(*a)+"0";
}
}
else
{
for(int i=n+2; i<(*a).size(); i++)
{
(*a).erase((*a).begin()+i);
i--;
}
}
}
int main()
{
int n;
string a,b;
cin>>n>>a>>b;
modity(&a);
modity(&b);//除去前导0;
int exponentA=0,exponentB=0;
solution(&a,&exponentA,n);
solution(&b,&exponentB,n);
if(a==b&&exponentA==exponentB)
{
printf("YES %s*10^%d\n",a.c_str(),exponentA);
}
else
{
printf("NO %s*10^%d %s*10^%d\n",a.c_str(),exponentA,b.c_str(),exponentB);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: