您的位置:首页 > 其它

Codeforces--629A--Far Relative’s Birthday Cake(暴力模拟)

2016-03-02 10:14 351 查看
Far Relative’s Birthday Cake

Time Limit: 1000MS Memory Limit: 262144KB 64bit IO Format: %I64d & %I64u
Submit

Status

Description

Door's family is going celebrate Famil Doors's birthday party. They love Famil Door so they are planning to make his birthday cake weird!

The cake is a n × n square consisting of equal squares with side length
1. Each square is either empty or consists of a single chocolate. They bought the cake and randomly started to put the chocolates on the cake. The value of Famil Door's happiness will be equal to the number of pairs of cells with
chocolates that are in the same row or in the same column of the cake. Famil Doors's family is wondering what is the amount of happiness of Famil going to be?

Please, note that any pair can be counted no more than once, as two different cells can't share both the same row and the same column.

Input

In the first line of the input, you are given a single integer
n (1 ≤ n ≤ 100) — the length of the side of the cake.

Then follow n lines, each containing
n characters. Empty cells are denoted with '.', while cells that contain chocolates are denoted by 'C'.

Output

Print the value of Famil Door's happiness, i.e. the number of pairs of chocolate pieces that share the same row or the same column.

Sample Input

Input
3
.CC
C..
C.C


Output
4


Input
4CC..
C..C
.CC.
.CC.


Output
9


Sample Output

Hint

If we number rows from top to bottom and columns from left to right, then, pieces that share the same row in the first sample are:

(1, 2) and (1, 3)
(3, 1) and (3, 3)

Pieces that share the same column are:
(2, 1) and (3, 1)
(1, 3) and (3, 3)
在同一行或者同一列的‘ C '的对数
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
struct node
{
int x,y;
}p[100100];
char map[110][110];
int main()
{
int cnt,n;
while(scanf("%d",&n)!=EOF)
{
cnt=0;
memset(map,0,sizeof(map));
for(int i=0;i<n;i++)
{
scanf("%s",map[i]);
for(int j=0;j<n;j++)
{
if(map[i][j]=='C')
{
p[cnt].x=i;
p[cnt++].y=j;
}
}
}
int ans=0;
for(int i=0;i<cnt;i++)
{
for(int j=0;j<cnt;j++)
{
if(i==j) continue;
if(p[i].x==p[j].x||p[i].y==p[j].y)
ans++;
}
}
printf("%d\n",ans/2);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: