您的位置:首页 > 其它

Wormholes

2016-03-01 15:07 246 查看
负权回路判断,有重边有自环,万能的spfa解决

http://poj.org/problem?id=3259

Wormholes

Time Limit: 2000MSMemory Limit: 65536K
Total Submissions: 39617Accepted: 14559
Description

While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way path that delivers you to its destination at a time that is BEFORE you entered the wormhole! Each of FJ's farms
comprises N (1 ≤ N ≤ 500) fields conveniently numbered 1..N, M (1 ≤ M≤ 2500) paths, and W (1
≤ W ≤ 200) wormholes.

As FJ is an avid time-traveling fan, he wants to do the following: start at some field, travel through some paths and wormholes, and return to the starting field a time before his initial departure. Perhaps he will be able to meet himself :) .

To help FJ find out whether this is possible or not, he will supply you with complete maps to F (1 ≤ F ≤ 5) of his farms. No paths will take longer than 10,000 seconds to travel and no
wormhole can bring FJ back in time by more than 10,000 seconds.

Input
Line 1: A single integer, F. F farm descriptions follow.

Line 1 of each farm: Three space-separated integers respectively: N, M, and W

Lines 2..M+1 of each farm: Three space-separated numbers (S, E, T) that describe, respectively: a bidirectional path between S and E that
requires T seconds to traverse. Two fields might be connected by more than one path.

Lines M+2..M+W+1 of each farm: Three space-separated numbers (S, E, T) that describe, respectively: A one way path from S to E that
also moves the traveler back Tseconds.
Output
Lines 1..F: For each farm, output "YES" if FJ can achieve his goal, otherwise output "NO" (do not include the quotes).
Sample Input
2
3 3 1
1 2 2
1 3 4
2 3 1
3 1 3
3 2 1
1 2 3
2 3 4
3 1 8

Sample Output
NO
YES

Hint
For farm 1, FJ cannot travel back in time.

For farm 2, FJ could travel back in time by the cycle 1->2->3->1, arriving back at his starting location 1 second before he leaves. He could start from anywhere on the cycle to accomplish this.
#include <cstdio>
#include <cstring>
#include <vector>
#include <algorithm>
#include <queue>
#define Min(a,b) a>b?b:a;
#define Max(a,b) a>b?a:b;
using namespace std;
const int SIZE=5e2+10;
const int maxn=1<<30;
struct node{
int v;int w;
node(){}
node(int vv,int ww):v(vv),w(ww){}
};
vector<vector<node> >G;
int cost[SIZE][SIZE];
int dis[SIZE];
bool spfa(int s,int n){
int uptimes[SIZE];
memset(uptimes,0,sizeof(uptimes));
for(int i=1;i<=n;i++)
dis[i]=maxn;
dis[s]=0;
queue<int>q;
q.push(s);
while(!q.empty()){
int u=q.front();
q.pop();
for(int i=0;i<G[u].size();i++){
int v=G[u][i].v;
int w=G[u][i].w;
if(w!=cost[u][v])continue;
if(dis[v]<=dis[u]+w)continue;
dis[v]=dis[u]+w;
q.push(v);
uptimes[v]++;
if(uptimes[v]>=n)return true;
}
}
return false;
}
int main()
{
int T;
scanf("%d",&T);
while(T--){
memset(cost,0,sizeof(cost));
int n,m,x,u,v,w;
scanf("%d%d%d",&n,&m,&x);
G.clear();
G.resize(n+10);
for(int i=0;i<m;i++){
scanf("%d%d%d",&u,&v,&w);
if(u==v)continue;
G[u].push_back(node(v,w));
G[v].push_back(node(u,w));
if(cost[u][v]){
cost[u][v]=cost[v][u]=Min(cost[v][u],w);
}
else cost[u][v]=cost[v][u]=w;
}
for(int i=0;i<x;i++){
scanf("%d%d%d",&u,&v,&w);
G[u].push_back(node(v,-w));
cost[u][v]=Min(cost[u][v],-w);
}
if(spfa(1,n))printf("YES\n");
else printf("NO\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: