您的位置:首页 > 其它

HDU 1035 Robot Motion

2016-02-27 16:28 197 查看
Description



A robot has been programmed to follow the instructions in its path. Instructions for the next direction the robot is to move are laid down in a grid. The possible instructions are

N north (up the page)

S south (down the page)

E east (to the right on the page)

W west (to the left on the page)

For example, suppose the robot starts on the north (top) side of Grid 1 and starts south (down). The path the robot follows is shown. The robot goes through 10 instructions in the grid before leaving the grid.

Compare what happens in Grid 2: the robot goes through 3 instructions only once, and then starts a loop through 8 instructions, and never exits.

You are to write a program that determines how long it takes a robot to get out of the grid or how the robot loops around.

Input

There will be one or more grids for robots to navigate. The data for each is in the following form. On the first line are three integers separated by blanks: the number of rows in the grid, the number of columns in the grid, and the
number of the column in which the robot enters from the north. The possible entry columns are numbered starting with one at the left. Then come the rows of the direction instructions. Each grid will have at least one and at most 10 rows and columns of instructions.
The lines of instructions contain only the characters N, S, E, or W with no blanks. The end of input is indicated by a row containing 0 0 0.

Output

For each grid in the input there is one line of output. Either the robot follows a certain number of instructions and exits the grid on any one the four sides or else the robot follows the instructions on a certain number of locations
once, and then the instructions on some number of locations repeatedly. The sample input below corresponds to the two grids above and illustrates the two forms of output. The word "step" is always immediately followed by "(s)" whether or not the number before
it is 1.

Sample Input

3 6 5
NEESWE
WWWESS
SNWWWW
4 5 1
SESWE
EESNW
NWEEN
EWSEN
0 0


Sample Output

10 step(s) to exit
3 step(s) before a loop of 8 step(s)


#include <stdio.h>
#include <string.h>
int main()
{
int y,x,n,start,i,j;
char str[500];
while (scanf("%d %d",&y,&x),x||y)
{
int cnt=0,pos[2],flag=-1,line[500][2],maps[500][500];
memset(line,-1,sizeof(line[500][2]));
scanf("%d",&n);
for(j=0;j<y;j++)
{
pos[0]=n-1,pos[1]=0;
scanf("%s",str);
for(i=0;i<x;i++)
{
switch(str[i])
{
case'N':maps[j][i]=1;break;
case'E':maps[j][i]=2;break;
case'S':maps[j][i]=3;break;
case'W':maps[j][i]=4;break;
}
}
}
for(cnt=0;pos[0]>=0&&pos[1]>=0&&pos[0]<x&&pos[1]<y&&flag==-1;cnt++)
{
int k;
line[cnt][0]=pos[0];
line[cnt][1]=pos[1];
switch(maps[pos[1]][pos[0]])
{
case 1:pos[1]--;break;
case 2:pos[0]++;break;
case 3:pos[1]++;break;
case 4:pos[0]--;break;
}
for(k=0;k<=cnt;k++)
{
if (pos[0]==line[k][0]&&pos[1]==line[k][1])
{
flag=k;
break;
}
}
}
if(flag==-1)
printf("%d step(s) to exit\n",cnt);
else printf("%d step(s) before a loop of %d step(s)\n",flag,cnt-flag);
}
}
思路就是存下来地图,然后根据地图标识决定行走方向,并存下来走过的位置,当走出地图或者走到曾经走过的位置上时,算法停止。
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: