您的位置:首页 > 其它

1018. Public Bike Management (30)

2016-02-27 16:06 351 查看
时间限制

400 ms

内存限制

65536 kB

代码长度限制

16000 B

判题程序

Standard

作者

CHEN, Yue

There is a public bike service in Hangzhou City which provides great convenience to the tourists from all over the world. One may rent a bike at any station and return it to any other stations in the city.

The Public Bike Management Center (PBMC) keeps monitoring the real-time capacity of all the stations. A station is said to be in perfect condition if it is exactly half-full. If a station is full or empty, PBMC will collect or send bikes to adjust the condition of that station to perfect. And more, all the stations on the way will be adjusted as well.

When a problem station is reported, PBMC will always choose the shortest path to reach that station. If there are more than one shortest path, the one that requires the least number of bikes sent from PBMC will be chosen.

Figure 1

Figure 1 illustrates an example. The stations are represented by vertices and the roads correspond to the edges. The number on an edge is the time taken to reach one end station from another. The number written inside a vertex S is the current number of bikes stored at S. Given that the maximum capacity of each station is 10. To solve the problem at S3, we have 2 different shortest paths:

PBMC -> S1 -> S3. In this case, 4 bikes must be sent from PBMC, because we can collect 1 bike from S1 and then take 5 bikes to S3, so that both stations will be in perfect conditions.

PBMC -> S2 -> S3. This path requires the same time as path 1, but only 3 bikes sent from PBMC and hence is the one that will be chosen.

Input Specification:

Each input file contains one test case. For each case, the first line contains 4 numbers: Cmax (<= 100), always an even number, is the maximum capacity of each station; N (<= 500), the total number of stations; Sp, the index of the problem station (the stations are numbered from 1 to N, and PBMC is represented by the vertex 0); and M, the number of roads. The second line contains N non-negative numbers Ci (i=1,…N) where each Ci is the current number of bikes at Si respectively. Then M lines follow, each contains 3 numbers: Si, Sj, and Tij which describe the time Tij taken to move betwen stations Si and Sj. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print your results in one line. First output the number of bikes that PBMC must send. Then after one space, output the path in the format: 0->S1->…->Sp. Finally after another space, output the number of bikes that we must take back to PBMC after the condition of Sp is adjusted to perfect.

Note that if such a path is not unique, output the one that requires minimum number of bikes that we must take back to PBMC. The judge’s data guarantee that such a path is unique.

Sample Input:

10 3 3 5

6 7 0

0 1 1

0 2 1

0 3 3

1 3 1

2 3 1

Sample Output:

3 0->2->3 0

与传统的最短路径不同,本题必须保存所有最短路径,然后进行DFS遍历,才能选择出最路径。

如果在PAT中遇到最短路径题型,时间又不足写出正解时,忽略最次条件,如本题中忽略带回车辆最少。进行一次检索,也能拿20分。是没有办法的办法。

#include<iostream>
#include<stack>
#include<vector>
#define maxn 505
#define INF 10000000
using namespace std;
int dist[maxn],c,n,s,m,g[maxn][maxn],w[maxn],minNeed=INF,minRemain=INF;
bool visited[maxn]={false};
vector<int> pre[maxn];
vector<int> tempPath,path;

int finddist(){
int MIN=INF,t=-1;
for(int i=0;i<=n;i++){
if(!visited[i]&&dist[i]<MIN){
MIN=dist[i];
t=i;
}
}
return t;
}
void Dijkstra(int s){
fill(dist,dist+maxn,INF);
for(int i=0;i<=n;i++){
pre[i].push_back(i);//初试化pre数组
}
dist[s]=0;
int v=finddist();
while(v!=-1){
visited[v]=true;
for(int i=0;i<=n;i++){
if(!visited[i]&&g[v][i]!=INF){
if(dist[i]>dist[v]+g[i][v]){
dist[i]=dist[v]+g[i][v];
pre[i].clear();
pre[i].push_back(v);
}
else if(dist[i]==dist[v]+g[v][i]){
pre[i].push_back(v);
}
}
}
v=finddist();
}
}
void DFS(int v){
if(v==0){//递归边界,叶子节点
tempPath.push_back(v);
int need=0,remain=0;
for(int i=tempPath.size()-1;i>=0;i--){
int id=tempPath[i];
if(w[id]>0){
remain+=w[id];
}else{
if(remain>abs(w[id])){
remain-=abs(w[id]);
}
else{
need+=abs(w[id])-remain;
remain=0;
}
}
}
if(need<minNeed){
minNeed=need;
minRemain=remain;
path=tempPath;
}else if(need=minNeed&&remain<minRemain){
minRemain=remain;
path=tempPath;
}
tempPath.pop_back();
return;
}
tempPath.push_back(v);
for(int i=0;i<pre[v].size();i++){
DFS(pre[v][i]);
}
tempPath.pop_back();
}
int main(){
int s1,s2,d;
scanf("%d%d%d%d",&c,&n,&s,&m);
c/=2;
fill(g[0],g[0]+maxn*maxn,INF);
for(int i=1;i<=n;i++){
scanf("%d",&w[i]);
w[i]-=c;
}
for(int i=0;i<m;i++){
scanf("%d%d",&s1,&s2);
scanf("%d",&g[s1][s2]);
g[s2][s1]=g[s1][s2];
}
Dijkstra(0);
DFS(s);
printf("%d ",minNeed);
for(int i=path.size()-1;i>=0;i--){
printf("%d",path[i]);
if(i>0) printf("->");
}
printf(" %d",minRemain);

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: