您的位置:首页 > 其它

HDU1059(多重背包)

2016-02-25 09:53 218 查看

Dividing

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 21883 Accepted Submission(s): 6174


[align=left]Problem Description[/align]
Marsha and Bill own a collection of marbles. They want to split the collection among themselves so that both receive an equal share of the marbles. This would be easy if all the marbles had the same value, because then they could just split the collection in half. But unfortunately, some of the marbles are larger, or more beautiful than others. So, Marsha and Bill start by assigning a value, a natural number between one and six, to each marble. Now they want to divide the marbles so that each of them gets the same total value.
Unfortunately, they realize that it might be impossible to divide the marbles in this way (even if the total value of all marbles is even). For example, if there are one marble of value 1, one of value 3 and two of value 4, then they cannot be split into sets of equal value. So, they ask you to write a program that checks whether there is a fair partition of the marbles.

[align=left]Input[/align]
Each line in the input describes one collection of marbles to be divided. The lines consist of six non-negative integers n1, n2, ..., n6, where ni is the number of marbles of value i. So, the example from above would be described by the input-line ``1 0 1 2 0 0''. The maximum total number of marbles will be 20000.

The last line of the input file will be ``0 0 0 0 0 0''; do not process this line.

[align=left]Output[/align]
For each colletcion, output ``Collection #k:'', where k is the number of the test case, and then either ``Can be divided.'' or ``Can't be divided.''.

Output a blank line after each test case.

[align=left]Sample Input[/align]

1 0 1 2 0 0

1 0 0 0 1 1

0 0 0 0 0 0

[align=left]Sample Output[/align]

Collection #1:
Can't be divided.
Collection #2:
Can be divided.

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int w[60005];
int dp[420005];
int a[6];
int main()
{
int cas=1;
while(scanf("%d%d%d%d%d%d",&a[0],&a[1],&a[2],&a[3],&a[4],&a[5])!=EOF)
{
memset(dp,0,sizeof(dp));
if(!a[0]&&!a[1]&&!a[2]&&!a[3]&&!a[4]&&!a[5])
break;
int cnt=0;
int sum=0;
for(int i=0;i<6;i++)
{
int v=i+1;
int e=1;
sum+=(v*a[i]);
while(e<a[i])
{
w[cnt++]=v*e;
a[i]-=e;
e<<=1;
}
if(a[i]>0)
w[cnt++]=a[i]*v;
}
printf("Collection #%d:\n",cas++);
if(sum%2!=0)//必须有
{
printf("Can't be divided.\n\n");
continue;
}

for(int i=0;i<cnt;i++)
for(int j=sum/2;j>=w[i];j--)
dp[j]=max(dp[j],dp[j-w[i]]+w[i]);

if(dp[sum/2]==sum/2)
printf("Can be divided.\n");
else
printf("Can't be divided.\n");
printf("\n");
}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: