您的位置:首页 > 其它

poj 1751 Highways

2016-02-24 19:17 281 查看
Highways

Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 12154 Accepted: 3489 Special Judge
Description

The island nation of Flatopia is perfectly flat. Unfortunately, Flatopia has a very poor system of public highways. The Flatopian government is aware of this problem and has already constructed a number of highways connecting some of the most important towns.
However, there are still some towns that you can't reach via a highway. It is necessary to build more highways so that it will be possible to drive between any pair of towns without leaving the highway system. 

Flatopian towns are numbered from 1 to N and town i has a position given by the Cartesian coordinates (xi, yi). Each highway connects exaclty two towns. All highways (both the original ones and the ones that are to be built) follow straight lines, and thus
their length is equal to Cartesian distance between towns. All highways can be used in both directions. Highways can freely cross each other, but a driver can only switch between highways at a town that is located at the end of both highways. 

The Flatopian government wants to minimize the cost of building new highways. However, they want to guarantee that every town is highway-reachable from every other town. Since Flatopia is so flat, the cost of a highway is always proportional to its length.
Thus, the least expensive highway system will be the one that minimizes the total highways length. 

Input

The input consists of two parts. The first part describes all towns in the country, and the second part describes all of the highways that have already been built. 

The first line of the input file contains a single integer N (1 <= N <= 750), representing the number of towns. The next N lines each contain two integers, xi and yi separated by a space. These values give the coordinates of ith town (for i from
1 to N). Coordinates will have an absolute value no greater than 10000. Every town has a unique location. 

The next line contains a single integer M (0 <= M <= 1000), representing the number of existing highways. The next M lines each contain a pair of integers separated by a space. These two integers give a pair of town numbers which are already connected by a
highway. Each pair of towns is connected by at most one highway. 

Output

Write to the output a single line for each new highway that should be built in order to connect all towns with minimal possible total length of new highways. Each highway should be presented by printing town numbers that this highway connects, separated by
a space. 

If no new highways need to be built (all towns are already connected), then the output file should be created but it should be empty. 

Sample Input
9
1 5
0 0
3 2
4 5
5 1
0 4
5 2
1 2
5 3
3
1 3
9 7
1 2

Sample Output
1 6
3 7
4 9
5 7
8 3

Source
Northeastern Europe 1999
这道题首先要注意的是只有一组测试数据,还有就是输出顺序可以和题目不一样(第一次见)
题意:村庄之间要修建铁路,给出村庄之间的坐标,并且有给出已连接的村庄,求需要建铁路的村庄

#include<stdio.h>
#include<string.h>
#include<math.h>
#include<algorithm>
# define max 810
using namespace std;
struct node
{
int x,y;
}t[max];
struct emge
{
int from,to,vis;
}e[max*max/2];
bool cmp(emge a,emge b)
{
return a.vis<b.vis;
}
int distance(int x1,int y1,int x2,int y2)
{
return (x1-x2)*(x1-x2)+(y1-y2)*(y1-y2);
}
int pre[max],c[max],d[max],num,n,m,k;
int find(int x)
{
if(x==pre[x])
return x;
return pre[x]=find(pre[x]);
}
void merge(int x,int y)
{
int fx=find(x);
int fy=find(y);
if(fx!=fy)
pre[fx]=fy;
}
void init()
{
int i;
for(i=0;i<110000;i++)
pre[i]=i;
}
void Kruskal()
{
num = 0;
for(int i = 0; i < k; i++)
{
int u = e[i].from;
int v = e[i].to;
if(find(u) != find(v))
{
merge(u, v);
c[num] = u + 1;
d[num] = v + 1;
num ++;
}
if(num >=n - 1)
break;
}
}
int main()
{
int i,j,a,b;
scanf("%d",&n);
{
init();
for(i=0;i<n;i++)
scanf("%d%d",&t[i].x,&t[i].y);
k=0;
for(i=0;i<n;i++)
for(j=i+1;j<n;j++)
{
e[k].from=i;
e[k].to=j;
e[k].vis=distance(t[i].x,t[i].y,t[j].x,t[j].y);
k++;
}
sort(e,e+k,cmp);
scanf("%d",&m);
for(i=0;i<m;i++)
{
scanf("%d%d",&a,&b);
a--;
b--;
if(find(a)!=find(b))
merge(a,b);
}
Kruskal();
for(i=0;i<num;i++)
printf("%d %d\n",c[i],d[i]);
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: