您的位置:首页 > 产品设计 > UI/UE

HDU_1711_NumberSequence

2016-02-21 21:28 393 查看


Number Sequence

Time Limit: 10000/5000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 18002 Accepted Submission(s): 7874



Problem Description

Given two sequences of numbers : a[1], a[2], ...... , a
, and b[1], b[2], ...... , b[M] (1 <= M <= 10000, 1 <= N <= 1000000). Your task is to find a number K which make a[K] = b[1], a[K + 1] = b[2], ...... , a[K + M - 1] = b[M]. If there are more than one
K exist, output the smallest one.

Input

The first line of input is a number T which indicate the number of cases. Each case contains three lines. The first line is two numbers N and M (1 <= M <= 10000, 1 <= N <= 1000000). The second line contains N integers which indicate a[1], a[2], ...... , a
.
The third line contains M integers which indicate b[1], b[2], ...... , b[M]. All integers are in the range of [-1000000, 1000000].

Output

For each test case, you should output one line which only contain K described above. If no such K exists, output -1 instead.

Sample Input

2
13 5
1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 1 3
13 5
1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 2 1


Sample Output

6
-1


Source

HDU 2007-Spring Programming Contest

Recommend

lcy

KMP的裸题

#include <iostream>
#include <stdio.h>
#include <string>
#include <string.h>
using namespace std;

const int MN=1e6+5;
const int MM=1e4+5;

int s1[MN],s2[MM];
int nex[MM];
int f;

void getnext(int m)
{
int j=0,k=-1;
nex[0]=-1;
while(j<m)
{
if(k==-1||s2[k]==s2[j])
nex[++j]=++k;
else
k=nex[k];
}
}
int getp(int m,int n)
{
int j=0,k=0;
while(j<n)
{
if(k==-1||s2[k]==s1[j])
{
k++;j++;
}
else
k=nex[k];
if(k==m)
return j-m+1;
}

return -1;
}

int main()
{
int t;
int n,m;
scanf("%d",&t);
while(t--)
{
f=-1;
memset(nex,0,sizeof(nex));
scanf("%d%d",&n,&m);
for(int i=0;i<n;i++)
scanf("%d",&s1[i]);
for(int i=0;i<m;i++)
scanf("%d",&s2[i]);
getnext(m);
//for(int i=0;i<10;i++)
//   cout<<i<<" "<<nex[i]<<endl;
printf("%d\n",getp(m,n));

}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: