您的位置:首页 > 编程语言 > C语言/C++

1031. Hello World for U (20)

2016-02-22 16:23 597 查看
Given any string of N (>=5) characters, you are asked to form the characters into the shape of U. For example, "helloworld" can be printed as:

h  d
e  l
l  r
lowo

That is, the characters must be printed in the original order, starting top-down from the left vertical line with n1 characters, then left to right along the bottom line with n2 characters, and finally bottom-up along the vertical line
with n3 characters. And more, we would like U to be as squared as possible -- that is, it must be satisfied that n1 = n3 = max { k| k <= n2 for all 3 <= n2 <= N } with n1 + n2 + n3
- 2 = N.
Input Specification:

Each input file contains one test case. Each case contains one string with no less than 5 and no more than 80 characters in a line. The string contains no white space.

Output Specification:

For each test case, print the input string in the shape of U as specified in the description.

Sample Input:
helloworld!

Sample Output:
h   !
e   d
l   l
lowor


#include <iostream>
#include <cstdio>

using namespace std;

int main(){
string s;
cin >> s;

int n = (int)s.size() + 2;
int n1, n2, n3;
int r = n % 3;

if(r == 0){
n1 = n2 = n3 = n / 3;
}else{
n2 = (n - r) / 3 + r;
n1 = n3 = (n - r) / 3;
}

int i = 0, j = (int)s.size() - 1;
for(; i < n1-1; ++i, --j){
printf("%c", s[i]);
for(int k = 0; k < n2-2; ++k)
printf(" ");
printf("%c\n", s[j]);
}

for(; i < n1+n2-1; ++i){
printf("%c", s[i]);
}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  C++ PAT Hello World for U