您的位置:首页 > 其它

[1032]:The 3n + 1 problem

2016-02-18 15:23 417 查看
Problem Description

Problems in Computer Science are often classified as belonging to a certain class of problems (e.g., NP, Unsolvable, Recursive). In this problem you will be analyzing a property of an algorithm whose classification is not known for all possible inputs.

Consider the following algorithm:

1. input n

2. print n

3. if n = 1 then STOP

4. if n is odd then n <- 3n + 1

5. else n <- n / 2

6. GOTO 2

Given the input 22, the following sequence of numbers will be printed 22 11 34 17 52 26 13 40 20 10 5 16 8 4 2 1

It is conjectured that the algorithm above will terminate (when a 1 is printed) for any integral input value. Despite the simplicity of the algorithm, it is unknown whether this conjecture is true. It has been verified, however, for all integers n such that 0 < n < 1,000,000 (and, in fact, for many more numbers than this.)

Given an input n, it is possible to determine the number of numbers printed (including the 1). For a given n this is called the cycle-length of n. In the example above, the cycle length of 22 is 16.

For any two numbers i and j you are to determine the maximum cycle length over all numbers between i and j.

Input

The input will consist of a series of pairs of integers i and j, one pair of integers per line. All integers will be less than 1,000,000 and greater than 0.

You should process all pairs of integers and for each pair determine the maximum cycle length over all integers between and including i and j.

You can assume that no opperation overflows a 32-bit integer.

Output

For each pair of input integers i and j you should output i, j, and the maximum cycle length for integers between and including i and j. These three numbers should be separated by at least one space with all three numbers on one line and with one line of output for each line of input. The integers i and j must appear in the output in the same order in which they appeared in the input and should be followed by the maximum cycle length (on the same line).

Sample Input

1 10

100 200

201 210

900 1000

Sample Output

1 10 20

100 200 125

201 210 89

900 1000 174

解题思路:

【刚看到这道题目,觉得好长啊,不过大概看一下,题目(被我加粗部分)是题目关键点,只要理解好,这道题就会变得很简单了】

1.输入数据满足只用int类型

2.输入的数ij谁大谁小没有限定

3.按照题目所给的运算规则,计算i~j区间每个数各自循环的次数

4.ij按输入的顺序输出并输出所给区间循环次数最大值

#include<stdio.h>

int main()
{
int i, j;
while(scanf("%d%d", &i, &j)!=EOF){

// a, b 能确保按输入输出,这里可以写成①
int a = i, b = j, maxLen = 0;

// 使i<j,可以写成②
if(i>j){
i = j - i;
j = j - i;
i = j + i;
}
int m = i;
for(; m<=j; m++){
int n = m, len = 1; // 输入一个数,len就是1
while(n!=1){
if(n%2==0){
n = n/2;
} else {
n = 3*n+1;
}
len++;
}

if(len > maxLen){
maxLen = len;
}
}
printf("%d %d %d\n", a, b, maxLen); // ①
}

return 0;
}




①可改成:

printf("%d %d ", i, j);


先输出再交换

②交换两个数的另外两种方式:

int temp = i;

i = j;

j = temp;


i = i^j;
j = i^j;
i = i^j;


内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: