您的位置:首页 > 其它

1002. A+B for Polynomials (25)

2016-02-18 09:50 260 查看
This time, you are supposed to find A+B where A and B are two polynomials.

Input

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial: K N1 aN1 N2 aN2 … NK aNK, where K is the number of nonzero terms in the polynomial, Ni and aNi (i=1, 2, …, K) are the exponents and coefficients, respectively. It is given that 1 <= K <= 10,0 <= NK < … < N2 < N1 <=1000.

Output

For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.

Sample Input

2 1 2.4 0 3.2

2 2 1.5 1 0.5

Sample Output

3 2 1.5 1 2.9 0 3.2

【翻译】:

两个多项式相加,系数精确到一位小数,指数属于0~1000

#include <stdio.h>
#include <string.h>
#include <math.h>
int main(){
float num[1005];
float tag=0;
int N1,i,posi,max=0,size=0;
scanf("%d",&N1);
memset(num,0.0,sizeof(num));

for(i=0;i<N1;i++){
scanf("%d%f",&posi,&tag);
num[posi] += tag;
if(max<posi)
max=posi;

size++;
}
scanf("%d",&N1);
for(i=0;i<N1;i++){
scanf("%d%f",&posi,&tag);
int a = num[posi];
num[posi] += tag;

if(fabs(a) < 1e-6)//通过这个来判断浮点数是不是很接近0
size++;
if(max<posi)
max=posi;
if(fabs(num[posi]) < 1e-6)
size=size-1;

}

printf("%d",size);
for(i=max;i>=0;i--)
if(!(fabs(num[i])<1e-6))
printf(" %d %.1f",i,num[i]);

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: