您的位置:首页 > 其它

hdu 2888 二维RMQ模板题

2016-02-17 21:16 211 查看


Check Corners

Time Limit: 2000/10000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 2377 Accepted Submission(s): 859



Problem Description

Paul draw a big m*n matrix A last month, whose entries Ai,j are all integer numbers ( 1 <= i <= m, 1 <= j <= n ). Now he selects some sub-matrices, hoping to find the maximum number. Then he finds that there may be more than one maximum number, he also wants
to know the number of them. But soon he find that it is too complex, so he changes his mind, he just want to know whether there is a maximum at the four corners of the sub-matrix, he calls this “Check corners”. It’s a boring job when selecting too many sub-matrices,
so he asks you for help. (For the “Check corners” part: If the sub-matrix has only one row or column just check the two endpoints. If the sub-matrix has only one entry just output “yes”.)



Input

There are multiple test cases.

For each test case, the first line contains two integers m, n (1 <= m, n <= 300), which is the size of the row and column of the matrix, respectively. The next m lines with n integers each gives the elements of the matrix which fit in non-negative 32-bit integer.

The next line contains a single integer Q (1 <= Q <= 1,000,000), the number of queries. The next Q lines give one query on each line, with four integers r1, c1, r2, c2 (1 <= r1 <= r2 <= m, 1 <= c1 <= c2 <= n), which are the indices of the upper-left corner
and lower-right corner of the sub-matrix in question.



Output

For each test case, print Q lines with two numbers on each line, the required maximum integer and the result of the “Check corners” using “yes” or “no”. Separate the two parts with a single space.



Sample Input

4 4
4 4 10 7
2 13 9 11
5 7 8 20
13 20 8 2
4
1 1 4 4
1 1 3 3
1 3 3 4
1 1 1 1




Sample Output

20 no
13 no
20 yes
4 yes


题意:

每次查询求解一个矩阵中的最大值,并判断是否与这个矩阵的四角相等。

/*
二维RMQ的思路与一维的大致相同,都是借助dp先进行预处理,然后快速查询
hhh-2016-01-30 01:59:55	
*/
#include <iostream>
#include <cstdio>
#include <cstring>
#include <ctime>
#include <algorithm>
#include <cmath>
#include <queue>
#include <map>
#include <vector>
typedef long long ll;
using namespace std;

const int maxn = 305;
int dp[maxn][maxn][9][9];
int tmap[maxn][maxn];
int mm[maxn];
void iniRMQ(int n,int m)
{
    for(int i = 1; i <= n; i++)
        for(int j = 1; j <= m; j++)
            dp[i][j][0][0] = tmap[i][j];
    for(int ti = 0; ti <= mm
; ti++)
        for(int tj = 0; tj <= mm[m]; tj++)
            if(ti+tj)
                for(int i = 1; i+(1<<ti)-1 <= n; i++)
                    for(int j = 1; j+(1<<tj)-1 <= m; j++)
                    {
                        if(ti)
                            dp[i][j][ti][tj] =
                                max(dp[i][j][ti-1][tj],dp[i+(1<<(ti-1))][j][ti-1][tj]);
                        else
                            dp[i][j][ti][tj] =
                                max(dp[i][j][ti][tj-1],dp[i][j+(1<<(tj-1))][ti][tj-1]);
                    }
}

int RMQ(int x1,int y1,int x2,int y2)
{
    int k1 = mm[x2-x1+1];
    int k2 = mm[y2-y1+1];
    x2 = x2 - (1<<k1) +1;
    y2 = y2 - (1<<k2) +1;
    return
        max(max(dp[x1][y1][k1][k2],dp[x1][y2][k1][k2]),
            max(dp[x2][y1][k1][k2],dp[x2][y2][k1][k2]));
}

int main()
{
    int n,m;
    mm[0] = -1;
    for(int i =1 ; i <= 301; i++)
        mm[i]  = ((i&(i-1)) == 0)? mm[i-1]+1:mm[i-1];
    while(scanf("%d%d",&n,&m)==2)
    {
        for(int i =1; i <= n; i++)
            for(int j = 1; j <= m; j++)
                scanf("%d",&tmap[i][j]);
        iniRMQ(n,m);
        int k;
        scanf("%d",&k);
        while(k--)
        {
            int x1,y1,x2,y2;
            scanf("%d%d%d%d",&x1,&y1,&x2,&y2);
            int ans = RMQ(x1,y1,x2,y2);
            printf("%d ",ans);

            if(ans == tmap[x1][y1] || ans == tmap[x1][y2]
                    || ans == tmap[x2][y1]|| ans == tmap[x2][y2])
                printf("yes\n");
            else
                printf("no\n");
        }
    }
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: