您的位置:首页 > 其它

POJ 3320 (尺取法 map)

2016-02-17 11:14 225 查看
Jessica's Reading Problem

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 9293 Accepted: 3018
Description

Jessica's a very lovely girl wooed by lots of boys. Recently she has a problem. The final exam is coming, yet she has spent little time on it. If she wants to pass it, she has to master all ideas included in a very thick text book. The author of that text
book, like other authors, is extremely fussy about the ideas, thus some ideas are covered more than once. Jessica think if she managed to read each idea at least once, she can pass the exam. She decides to read only one contiguous part of the book which contains
all ideas covered by the entire book. And of course, the sub-book should be as thin as possible.

A very hard-working boy had manually indexed for her each page of Jessica's text-book with what idea each page is about and thus made a big progress for his courtship. Here you come in to save your skin: given the index, help Jessica decide which contiguous
part she should read. For convenience, each idea has been coded with an ID, which is a non-negative integer.

Input

The first line of input is an integer P (1 ≤ P ≤ 1000000), which is the number of pages of Jessica's text-book. The second line contains P non-negative integers describing what idea each page is about. The first integer is what
the first page is about, the second integer is what the second page is about, and so on. You may assume all integers that appear can fit well in the signed 32-bit integer type.

Output

Output one line: the number of pages of the shortest contiguous part of the book which contains all ideals covered in the book.

Sample Input
5
1 8 8 8 1

Sample Output
2

Source

POJ Monthly--2007.08.05, Jerry
题意是n本书最少读连续的几页可以获得所有的知识点。

设定两个头尾指针然后每次在可行的情况下不断推进,然后维护知识点出现的次数,由于知识点是离散的开个map记录下,维护头尾指针差的最小值。

#include <iostream>
#include <cmath>
#include <cstdlib>
#include <time.h>
#include <vector>
#include <cstdio>
#include <cstring>
#include <map>
#include <algorithm>
using namespace std;
#define maxn 1111111

map<int, int> gg;
int n, a[maxn], b[maxn];

int main () {
while (scanf ("%d", &n) == 1) {
for (int i = 1; i <= n; i++) {
scanf ("%d", &a[i]);
b[i] = a[i];
}
sort (b+1, b+1+n); b[0] = -1;
int k = 0;
for (int i = 1; i <= n; i++) {
if (b[i] != b[i-1])
k++;
}
gg.clear ();
int l = 1, r = 1, cnt = 0, ans = 1111111;
for (; ; r++) {
int cur = a[r];
if (!gg.count (cur)) {
cnt++;
gg[cur] = 1;
}
else {
gg[cur]++;
}
if (cnt == k)
break;
}
while (gg[a[l]] > 1) {
gg[a[l]]--;
l++;
}
ans = r-l+1;
for (r = r+1; r <= n; r++) {
int cur = a[r];
gg[cur]++;
while (gg[a[l]] > 1) {
gg[a[l]]--;
l++;
}
ans = min (ans, r-l+1);
}
printf ("%d\n", ans);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: