您的位置:首页 > 其它

HDU3466(01背包变种)

2016-02-12 17:03 239 查看

Proud Merchants

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 131072/65536 K (Java/Others)
Total Submission(s): 4219 Accepted Submission(s): 1740


[align=left]Problem Description[/align]
Recently, iSea went to an ancient country. For such a long time, it was the most wealthy and powerful kingdom in the world. As a result, the people in this country are still very proud even if their nation hasn’t been so wealthy any more.
The merchants were the most typical, each of them only sold exactly one item, the price was Pi, but they would refuse to make a trade with you if your money were less than Qi, and iSea evaluated every item a value Vi.
If he had M units of money, what’s the maximum value iSea could get?

[align=left]Input[/align]
There are several test cases in the input.

Each test case begin with two integers N, M (1 ≤ N ≤ 500, 1 ≤ M ≤ 5000), indicating the items’ number and the initial money.
Then N lines follow, each line contains three numbers Pi, Qi and Vi (1 ≤ Pi ≤ Qi ≤ 100, 1 ≤ Vi ≤ 1000), their meaning is in the description.

The input terminates by end of file marker.

[align=left]Output[/align]
For each test case, output one integer, indicating maximum value iSea could get.

[align=left]Sample Input[/align]

2 10
10 15 10
5 10 5
3 10
5 10 5
3 5 6
2 7 3

[align=left]Sample Output[/align]

5
11
题意:有n个商品,买第i个需要Pi元,但手中的钱必须大于Qi元 ,所获得的价值为Vi,问给出M元,获得的最大价值为多少?
思路: 每个商品按q-p排序才会得到正确结果

#include"cstdio"
#include"cstring"
#include"algorithm"
using namespace std;
const int MAXN=1005;
struct Node{
int P,Q,v;
}goods[505];
int n,W;
int dp[5005];
int comp(Node a,Node b)
{
return a.Q-a.P < b.Q-b.P;
}
int main()
{
while(scanf("%d%d",&n,&W)!=EOF)
{
memset(dp,0,sizeof(dp));
for(int i=0;i<n;i++)
{
scanf("%d%d%d",&goods[i].P,&goods[i].Q,&goods[i].v);
}
sort(goods,goods+n,comp);
for(int i=0;i<n;i++)
{
for(int j=W;j>=goods[i].Q;j--)    dp[j]=max(dp[j],dp[j-goods[i].P]+goods[i].v);
}
printf("%d\n",dp[W]);
}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: