您的位置:首页 > 其它

1009. Product of Polynomials (25)

2016-02-10 22:24 363 查看


1009. Product of Polynomials (25)

时间限制

400 ms

内存限制

65536 kB

代码长度限制

16000 B

判题程序

Standard

作者

CHEN, Yue

This time, you are supposed to find A*B where A and B are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial: K N1 aN1 N2 aN2 ... NK aNK, where
K is the number of nonzero terms in the polynomial, Ni and aNi (i=1, 2, ..., K) are the exponents and coefficients, respectively. It is given tha
a8aa
t 1 <= K <= 10, 0 <= NK < ... < N2 < N1 <=1000.

Output Specification:

For each test case you should output the product of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate up to 1 decimal place.
Sample Input
2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output
3 3 3.6 2 6.0 1 1.6

#include <iostream>
#include <vector>
#include <stdio.h>
#include <map>
using namespace std;
typedef pair<int, double> term;
int main(){
vector<term> polynomial1;
vector<term> polynomial2;
map<int,double,greater<int>> result;
int n1,n2,temp1;
double temp2;
cin>>n1;
for (int i=0; i<n1; i++) {
cin>>temp1>>temp2;
polynomial1.push_back(term(temp1,temp2));
}
cin>>n2;
for (int i=0; i<n2; i++) {
cin>>temp1>>temp2;
polynomial2.push_back(term(temp1,temp2));
}
for (int i=0; i<n1; i++) {
for (int j=0; j<n2; j++) {
int exponents;//指数,系数.
float coefficients;
exponents = polynomial1[i].first+polynomial2[j].first;
coefficients =polynomial1[i].second*polynomial2[j].second;
result[exponents]+=coefficients;
}
}
int count=0;
for (auto it=result.begin(); it!=result.end(); it++)
if(it->second!=0)
count++;
cout<<count;
for (auto it=result.begin(); it!=result.end(); it++)
{
if(it->second!=0)
printf(" %d %.1lf",it->first,it->second);
}
cout<<endl;
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: