您的位置:首页 > 其它

broken keyboards

2016-02-10 11:44 274 查看
You're typing a long text with a broken keyboard. Well it's not so badly broken. The only problem

with the keyboard is that sometimes the \home" key or the \end" key gets automatically pressed

(internally).

You're not aware of this issue, since you're focusing on the text and did not even turn on the

monitor! After you nished typing, you can see a text on the screen (if you turn on the monitor).

In Chinese, we can call it Beiju. Your task is to nd the Beiju text.

Input

There are several test cases. Each test case is a single line containing at least one and at most 100,000

letters, underscores and two special characters `[' and `]'. `[' means the \Home" key is pressed

internally, and `]' means the \End" key is pressed internally. The input is terminated by end-of- le

(EOF).

Output

For each case, print the Beiju text on the screen.

Sample Input

This_is_a_[Beiju]_text

[[]][][]Happy_Birthday_to_Tsinghua_University

Sample Output

BeijuThis_is_a__text

Happy_Birthday_to_Tsinghua_University

代码如下:

#include<iostream>

#include<string.h>

using namespace std;

char s[1000007];

int c,l,next[1000007];

int main()

{

int i;

while(cin>>s+1)

{

int n=strlen(s+1);

c=l=0;

next[0]=0;

for(i=1;i<=n;i++)

{

if(s[i]=='[')

c=0;

else if(s[i]==']')

c=l;

else

{

next[i]=next[c];

next[c]=i;

if(c==l)

l=i;

c=i;

}

}

for(i=next[0];i!=0;i=next[i])

{

cout<<s[i];

}

cout<<endl;

}

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: