您的位置:首页 > 其它

集训队专题(3)1003 Minimum Transport Cost

2016-02-05 00:43 260 查看


Minimum Transport Cost

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 9275 Accepted Submission(s): 2461



Problem Description

These are N cities in Spring country. Between each pair of cities there may be one transportation track or none. Now there is some cargo that should be delivered from one city to another. The transportation fee consists of two parts:

The cost of the transportation on the path between these cities, and

a certain tax which will be charged whenever any cargo passing through one city, except for the source and the destination cities.

You must write a program to find the route which has the minimum cost.

Input

First is N, number of cities. N = 0 indicates the end of input.

The data of path cost, city tax, source and destination cities are given in the input, which is of the form:

a11 a12 ... a1N

a21 a22 ... a2N

...............

aN1 aN2 ... aNN

b1 b2 ... bN

c d

e f

...

g h

where aij is the transport cost from city i to city j, aij = -1 indicates there is no direct path between city i and city j. bi represents the tax of passing through city i. And the cargo is to be delivered from city c to city d, city e to city f, ..., and
g = h = -1. You must output the sequence of cities passed by and the total cost which is of the form:

Output

From c to d :

Path: c-->c1-->......-->ck-->d

Total cost : ......

......

From e to f :

Path: e-->e1-->..........-->ek-->f

Total cost : ......

Note: if there are more minimal paths, output the lexically smallest one. Print a blank line after each test case.

Sample Input

5
0 3 22 -1 4
3 0 5 -1 -1
22 5 0 9 20
-1 -1 9 0 4
4 -1 20 4 0
5 17 8 3 1
1 3
3 5
2 4
-1 -1
0


Sample Output

From 1 to 3 :
Path: 1-->5-->4-->3
Total cost : 21

From 3 to 5 :
Path: 3-->4-->5
Total cost : 16

From 2 to 4 :
Path: 2-->1-->5-->4
Total cost : 17


Source

Asia 1996, Shanghai (Mainland China)

此题的难点不在求最短路径上,而在输出路径上。

题意:有N个城市,然后直接给出这些城市之间的邻接矩阵,矩阵中-1代表那两个城市无道路相连,其他值代表路径长度。如果一辆汽车经过某个城市,必须要交一定的钱(小编理解为过路费……)。现在要从a城到b城,花费为路径长度之和,再加上除起点与终点外所有城市的过路费之和。求最小花费,如果有多条路经符合,则输出字典序最小的路径。

就像小编之前说的,此题难在输出上,题目的关键还要按照字典序输出字典序最小路径。求最短路径上小编这里还是用代码量最小的,最简单粗暴的Floyd算法,在字典序上需要进行一些判断。

#include <cstdio>
#include <cstring>
#define INF 0xfffffff
#define N 500+5
int map

,tax
,path

;
int n;
void init()
{
int i,j;
for(i=1; i<=n; i++)
{
for(j=1; j<=n; j++)
{
if(i == j) map[i][j] = 0;
else map[i][j] = INF;
}
}
}
void input()
{
int i,j,k;
for(i=1; i<=n; i++)
{
for(j=1; j<=n; j++)
{
scanf("%d",&k);
if(k!=-1) map[i][j] = k;
path[i][j] = j;
}
}
for(i=1; i<=n; i++) scanf("%d",&tax[i]);
}
void floyd()
{
int i,j,k,len;
for(k=1; k<=n; k++)
{
for(i=1; i<=n; i++)
{
for(j=1; j<=n; j++)
{
len = map[i][k]+map[k][j]+tax[k];
if(map[i][j] > len)
{
map[i][j] = len;
path[i][j] = path[i][k];
}
else if(map[i][j] == len)
{
if(path[i][j] > path[i][k])
path[i][j] = path[i][k];
}
}
}
}
}
void output()
{
int i,j,k;
while(scanf("%d%d",&i,&j)&&(i!=-1&&j!=-1))
{
printf("From %d to %d :\n", i, j);
printf("Path: %d", i);
k = i;
while(k != j)
{
printf("-->%d", path[k][j]);
k = path[k][j];
}
printf("\n");
printf("Total cost : %d\n\n", map[i][j]);
}
}
int main()
{
while(scanf("%d",&n)&&n!=0)
{
init();
input();
floyd();
output();
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: