您的位置:首页 > 其它

POJ 1017:Packets【细心】

2016-02-04 21:51 357 查看
Packets

Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 49073 Accepted: 16624
Description

A factory produces products packed in square packets of the same height h and of the sizes 1*1, 2*2, 3*3, 4*4, 5*5, 6*6. These products are always delivered to customers in the square parcels of the same height h as the products have and of the size 6*6. Because
of the expenses it is the interest of the factory as well as of the customer to minimize the number of parcels necessary to deliver the ordered products from the factory to the customer. A good program solving the problem of finding the minimal number of parcels
necessary to deliver the given products according to an order would save a lot of money. You are asked to make such a program.
Input

The input file consists of several lines specifying orders. Each line specifies one order. Orders are described by six integers separated by one space representing successively the number of packets of individual size from the smallest size 1*1 to the biggest
size 6*6. The end of the input file is indicated by the line containing six zeros.
Output

The output file contains one line for each line in the input file. This line contains the minimal number of parcels into which the order from the corresponding line of the input file can be packed. There is no line in the output file corresponding to the last
``null'' line of the input file.
Sample Input
0 0 4 0 0 1
7 5 1 0 0 0
0 0 0 0 0 0

Sample Output
2
1

AC—code:

我自己的:

#include<stdio.h>
int main()
{
int a,b,c,d,e,f,cnt;
while(scanf("%d%d%d%d%d%d",&a,&b,&c,&d,&e,&f),a||b||c||e||f||d)
{
cnt=f;
cnt+=e;
if(a>=11*e)
a-=11*e;
else
a=0;
cnt+=d;
if(b>=5*d)
b-=5*d;
else
{
if(a>=20*d-4*b)
a-=20*d-4*b;
else
a=0;
b=0;
}
cnt+=(c+3)/4;
c=c%4;
if(c==1)
{
if(b>=5)
{
b-=5;
if(a>=7)
a-=7;
else
a=0;
}
else
{
if(a>=27-4*b)
a-=27-4*b;
else
a=0;
b=0;
}
}
else if(c==2)
{
if(b>=3)
{
b-=3;
if(a>=6)
a-=6;
else
a=0;
}
else
{
if(a>=18-4*b)
a-=18-4*b;
else
a=0;
b=0;
}
}
if(c==3)
{
if(b)
{
b--;
if(a>=5)
a-=5;
else
a=0;
}
else
{
if(a>=9)
a-=9;
else
a=0;
}
}
cnt+=(b+8)/9;
b=b%9;
if(b)
{
if(a>=36-4*b)
a-=36-4*b;
else
a=0;
b=0;
}
cnt+=(a+35)/36;
printf("%d\n",cnt);
}
return 0;
}

看讨论区的:
#include<cstdio>
int main()
{
int a,b,c,d,e,f,n,x,y;
int u[4]={0,5,3,1};
while(scanf("%d%d%d%d%d%d",&a,&b,&c,&d,&e,&f),a||b||c||d||e||f)
{
n=f+e+d+(c+3)/4;
y=5*d+u[c%4];
if(b>y)
n+=(b-y+8)/9;
x=36*n-36*f-25*e-16*d-9*c-4*b;
if(a>x)
n+=(a-x+35)/36;
printf("%d\n",n);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: