您的位置:首页 > 其它

纵横字谜的答案

2016-02-03 16:32 302 查看
纵横字谜的答案

Time Limit:3000MS Memory Limit:0KB 64bit IO Format:%lld & %llu

Submit

Status

Description

Download as PDF

Crossword Answers

A crossword puzzle consists of a rectangular grid of black and white squares and two lists of definitions (or descriptions).

One list of definitions is for ``words" to be written left to right across white squares in the rows and the other list is for words to be written down white squares in the columns. (A word is a sequence of alphabetic characters.)

To solve a crossword puzzle, one writes the words corresponding to the definitions on the white squares of the grid.

The definitions correspond to the rectangular grid by means of sequential integers on ``eligible" white squares. White squares with black squares immediately to the left or above them are ``eligible." White squares with no squares either immediately to the
left or above are also ``eligible." No other squares are numbered. All of the squares on the first row are numbered.

The numbering starts with 1 and continues consecutively across white squares of the first row, then across the eligible white squares of the second row, then across the eligible white squares of the third row and so on across all of the rest of the rows of
the puzzle. The picture below illustrates a rectangular crossword puzzle grid with appropriate numbering.

An ``across" word for a definition is written on a sequence of white squares in a row starting on a numbered square that does not follow another white square in the same row.

The sequence of white squares for that word goes across the row of the numbered square, ending immediately before the next black square in the row or in the rightmost square of the row.

A ``down" word for a definition is written on a sequence of white squares in a column starting on a numbered square that does not follow another white square in the same column.

The sequence of white squares for that word goes down the column of the numbered square, ending immediately before the next black square in the column or in the bottom square of the column.

Every white square in a correctly solved puzzle contains a letter.

You must write a program that takes several solved crossword puzzles as input and outputs the lists of across and down words which constitute the solutions.

Input

Each puzzle solution in the input starts with a line containing two integers r and c ( tex2html_wrap_inline39 and tex2html_wrap_inline41 ), where r (the first number) is the number of rows in the puzzle and c (the second number) is the number of columns.

The r rows of input which follow each contain c characters (excluding the end-of-line) which describe the solution. Each of those ccharacters is an alphabetic character which is part of a word or the character ``*", which indicates a black square.

The end of input is indicated by a line consisting of the single number 0.

Output

Output for each puzzle consists of an identifier for the puzzle (puzzle #1:, puzzle #2:, etc.) and the list of across words followed by the list of down words. Words in each list must be output one-per-line in increasing order of the number of their corresponding
definitions.

The heading for the list of across words is ``Across". The heading for the list of down words is ``Down".

In the case where the lists are empty (all squares in the grid are black), the Across and Down headings should still appear.

Separate output for successive input puzzles by a blank line.

Sample Input

2 2

AT

*O

6 7

AIM*DEN

*ME*ONE

UPON*TO

SO*ERIN

*SA*OR*

IES*DEA

0

Sample Output

puzzle #1:

Across

1.AT

3.O

Down

1.A

2.TO

puzzle #2:

Across

1.AIM

4.DEN

7.ME

8.ONE

9.UPON

11.TO

12.SO

13.ERIN

15.SA

17.OR

18.IES

19.DEA

Down

1.A

2.IMPOSE

3.MEO

4.DO

5.ENTIRE

6.NEON

9.US

10.NE

14.ROD

16.AS

18.I

20.A

这个题目做的时候我觉得注意的是格式,如果只有一个例子当测试数据就不需要最后的空格,还有数字的输出格式。其他的多细心就好,说实话,感觉自己写的代码还是太啰嗦,,,,上代码

#include <cstdio>

#include <iostream>

#include <algorithm>

using namespace std;

struct biao

{

char su;

int number;

int flag;

};

int main()

{

biao x[1000][11];

int a,b;

int jishuqi=1;

while(scanf("%d",&a)!=EOF)

{

if (a==0)break;

scanf("%d",&b);

getchar();

int count=1;

for (int number1=0;number1<a;number1++)

{

for (int number2=0;number2<b;number2++)

{

scanf("%c",&x[number1][number2].su);

x[number1][number2].number=0;

x[number1][number2].flag=0;

}

getchar();

}

for (int number1=0;number1<a;number1++)

{

for (int number2=0;number2<b;number2++)

{

if((number1-1<0||number2-1<0||x[number1-1][number2].su=='*'||x[number1][number2-1].su=='*')

&&x[number1][number2].su!='*')

{

x[number1][number2].number=count;

count++;

}

}

}

int biaozhi=1;

if (jishuqi!=1)

{

printf("\n");

}

printf("puzzle #%d:\n",jishuqi);

jishuqi++;

printf("Across\n");

for (int number1=0;number1<a;number1++)

{

for (int number2=0;number2<b;number2++)

{

if (biaozhi==1)

{

if (x[number1][number2].su!='*')

{

printf("%3d.",x[number1][number2].number);

biaozhi=-1;

}

}

if (x[number1][number2].su!='*')

{

printf("%c",x[number1][number2].su);

if (number2==b-1)

{

biaozhi=1;

printf("\n");

}

else if (x[number1][number2+1].su=='*')

{

biaozhi=1;

printf("\n");

}

}

}

}

printf("Down\n");

for (int number1=0;number1<a;number1++)

{

for (int number2=0;number2<b;number2++)

{

if (biaozhi==1)

{

if (x[number1][number2].su!='*'&&x[number1][number2].flag==0)

{

printf("%3d.",x[number1][number2].number);

biaozhi=-1;

for (int number3=number1;number3<a;number3++)

{

if (x[number3][number2].su!='*'&&x[number3][number2].flag==0)

{

printf("%c",x[number3][number2].su);

x[number3][number2].flag=-1;

}

else if (x[number3][number2].su=='*')

{

break;

}

}

biaozhi=1;

printf("\n");

}

}

}

}

}

return 0;

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: