您的位置:首页 > 其它

结构体排序

2016-02-01 20:46 225 查看


Description

Excel可以对一组纪录按任意指定列排序。现请你编写程序实现类似功能。

Input

测试输入包含若干测试用例。每个测试用例的第1行包含两个整数 N (<=100000) 和 C,其中 N 是纪录的条数,C 是指定排序的列号。以下有 N

行,每行包含一条学生纪录。每条学生纪录由学号(6位数字,同组测试中没有重复的学号)、姓名(不超过8位且不包含空格的字符串)、成绩(闭区间[0, 100]内的整数)组成,每个项目间用1个空格隔开。当读到 N=0 时,全部输入结束,相应的结果不要输出。

Output

对每个测试用例,首先输出1行“Case i:”,其中 i 是测试用例的编号(从1开始)。随后在 N 行中输出按要求排序后的结果,即:当 C=1 时,按学号递增排序;当 C=2时,按姓名的非递减字典序排序;当 C=3

时,按成绩的非递减排序。当若干学生具有相同姓名或者相同成绩时,则按他们的学号递增排序。

Sample Input

3 1
000007 James 85
000010 Amy 90
000001 Zoe 60
4 2
000007 James 85
000010 Amy 90
000001 Zoe 60
000002 James 98
4 3
000007 James 85
000010 Amy 90
000001 Zoe 60
000002 James 90
0 0


Sample Output

Case 1:
000001 Zoe 60
000007 James 85
000010 Amy 90
Case 2:
000010 Amy 90
000002 James 98
000007 James 85
000001 Zoe 60
Case 3:
000001 Zoe 60
000007 James 85
000002 James 90
000010 Amy 90


我的代码:

#include <cstdio>

#include <algorithm>

#include <cstdlib>

#include <cstring>

#include <iostream>

using namespace std;

const int MAXN = 1e5 + 10;

typedef struct Student

{

char name[9];

int score, num;

}Stu[MAXN];

Stu S;

int cmp_num(const void *a, const void *b)

{

return ((Student *)a)->num - ((Student *)b)->num;

}

int cmp_sco(const void *a, const void *b)

{

struct Student *c = (Student *)a;

struct Student *d = (Student *)b;

if(c->score != d->score)

return c->score - d->score;

else

return c->num - d->num;

}

int cmp_name(const void *a,const void *b)

{

if(strcmp((((Student *)a)->name), ((Student *)b)->name))

return strcmp((((Student *)a)->name), ((Student *)b)->name);

else

return ((Student *)a)->num - ((Student *)b)->num;

}

int main()

{

int n, N, c, j, i = 1;

while(scanf("%d%d", &n, &c) && n)

{

N = n;

j = 0;

while( N-- )

{

scanf("%d", &S[j].num);

scanf("%s", S[j].name);

scanf("%d", &S[j].score);

j++;

}

if(1 == c)

{

qsort(S, n, sizeof(S[0]), cmp_num);

}

else if(2 == c)

{

qsort(S, n, sizeof(S[0]), cmp_name);

}

else if(3 == c)

{

qsort(S, n, sizeof(S[0]), cmp_sco);

}

printf("Case %d:\n", i++);

for( j=0; j < n; j++ )

printf("%06d %s %d\n", S[j].num, S[j].name, S[j].score);

}

return 0;

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: