您的位置:首页 > 其它

poj 3672 Long Distance Racing

2016-01-30 11:32 204 查看
<span style="font-size: 18pt; font-family: Arial, Helvetica, sans-serif; background-color: rgb(255, 255, 255);">Description</span>


Bessie is training for her next race by running on a path that includes hills so that she will be prepared for any terrain. She has planned a straight path and wants to run as far as she can -- but she must be back to the farm within M seconds (1
≤ M ≤ 10,000,000).

The entire path she has chosen is T units (1 ≤ T ≤ 100,000) in length and consists of equal-length portions that are uphill, flat, or downhill. The input data describes path segment i with a single character Si that is u, f,
or d, indicating respectively uphill, flat, or downhill.

Bessie takes U seconds (1 ≤ U ≤ 100) to run one unit of uphill path, F (1 ≤ F ≤ 100) seconds for a unit of flat path, and D (1 ≤ D ≤ 100) seconds for a unit of downhill path. Note that, when returning
home, uphill paths become downhill paths and downhill paths become uphill paths.

Find the farthest distance Bessie can get from the farm and still make it back in time.

Input

* Line 1: Five space-separated integers: M, T, U, F, and D

* Lines 2..T+1: Line i+1 describes path segment i with a single letter: Si

Output

* Line 1: A single integer that is the farthest distance (number of units) that Bessie can get from the farm and make it back in time.

Sample Input
13 5 3 2 1
u
f
u
d
f

Sample Output
3

这道题比较简单;
直接将去的路程和返回的路程一起算就行了;

</pre><pre name="code" class="cpp">#include<iostream>
#include<algorithm>
#include<cstdio>
#include<cstring>
#include<string>
using namespace std;
char s[1000005];
int main()
{
int M,T,U,F,D;
scanf("%d %d %d %d %d",&M,&T,&U,&F,&D);
int sum=0,t=0;
for(int i=0;i<T;++i)
{
scanf(" %c",&s[i]);
}
for(int i=0;i<T;++i)
{
if(t>=M) break;
if(s[i]=='f')
{
t+=2*F;
if(t<=M) ++sum;
}
else if(s[i]=='u'||s[i]=='d')
{
t+=U+D;
if(t<=M) ++sum;
}
}
printf("%d\n",sum);
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: