您的位置:首页 > 其它

HDU-1506-Largest Rectangle in a Histogram【思维】【dp】【好题】

2016-01-28 19:36 477 查看

HDU-1506-Largest Rectangle in a Histogram

[code]        Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)


Problem Description

A histogram is a polygon composed of a sequence of rectangles aligned at a common base line. The rectangles have equal widths but may have different heights. For example, the figure on the left shows the histogram that consists of rectangles with the heights 2, 1, 4, 5, 1, 3, 3, measured in units where 1 is the width of the rectangles:




Usually, histograms are used to represent discrete distributions, e.g., the frequencies of characters in texts. Note that the order of the rectangles, i.e., their heights, is important. Calculate the area of the largest rectangle in a histogram that is aligned at the common base line, too. The figure on the right shows the largest aligned rectangle for the depicted histogram.

Input

The input contains several test cases. Each test case describes a histogram and starts with an integer n, denoting the number of rectangles it is composed of. You may assume that 1 <= n <= 100000. Then follow n integers h1, …, hn, where 0 <= hi <= 1000000000. These numbers denote the heights of the rectangles of the histogram in left-to-right order. The width of each rectangle is 1. A zero follows the input for the last test case.

Output

For each test case output on a single line the area of the largest rectangle in the specified histogram. Remember that this rectangle must be aligned at the common base line.

Sample Input

7 2 1 4 5 1 3 3

4 1000 1000 1000 1000

0

Sample Output

8

4000

题目链接:HDU-1506

题目大意:有n个矩形连在一起,给出每个矩形的长,宽固定为1.问,所能组成的矩形的最大面积

题目思路:这道题比较考思维,刚开始一直想两个矩形前后之间关系来dp,发现讨论的很复杂而且还存在bug。

搜了题解,发现解法挺巧妙的。

主要思路就是找出以当前点位最低点能左右延伸的最长距离,也就是找出最左最右的下标,最后的 ans = max(s[i]*(r[i]-l[i]+1))

以下是代码:

[code]#include <vector>
#include <map>
#include <set>
#include <algorithm>
#include <iostream>
#include <cstdio>
#include <cmath>
#include <cstdlib>
#include <string>
#include <cstring>
using namespace std;
int num[100010];
int l[100010];
int r[100010];
int main(){
    int n;
    while(cin >> n && n)
    {
        for (int i = 1; i <= n; i++)
        {
            cin >> num[i];
            l[i] = i;
            r[i] = i;
        }   
        num[n + 1] = num[0] = -1;
        for (int i = 1; i <= n; i++)
        {
            while(num[l[i] - 1] >= num[i])
            {
                l[i] = l[l[i] - 1];   //记录最左边的位置
            }
        }
        for (int i = n; i > 0; i--)
        {
            while(num[r[i] + 1] >= num[i])
            {
                r[i] = r[r[i] + 1];  //记录最右边的位置
            }
        }
        long long ans = 0;
        for (int i = 1; i <= n; i++)
        {
            ans = max(ans,(long long)num[i] * (r[i] - l[i] + 1));  //以num[i]为最低点所能构建的矩形面积取最大值
        }
        cout << ans << endl;
    }
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: