您的位置:首页 > 产品设计 > UI/UE

CDUESTC 2016 假期赛1 E题

2016-01-23 17:37 423 查看
E - find the nth digit
Time Limit:1000MS     Memory Limit:32768KB     64bit
IO Format:
%I64d & %I64u

Description

假设: 
S1 = 1 
S2 = 12 
S3 = 123 
S4 = 1234 
......... 
S9 = 123456789 
S10 = 1234567891 
S11 = 12345678912 
............ 
S18 = 123456789123456789 
.................. 
现在我们把所有的串连接起来 
S = 1121231234.......123456789123456789112345678912......... 
那么你能告诉我在S串中的第N个数字是多少吗? 

Input

输入首先是一个数字K,代表有K次询问。 
接下来的K行每行有一个整数N(1 <= N < 2^31)。

Output

对于每个N,输出S中第N个对应的数字. 

 

Sample Input

6132410 5

Sample Output

111224

此题我做的时间最久......我是不知道有没有什么规律,我直接大暴力过的.....数据可能会很大,所以定义全局变量吧。
<div style="text-align: left;"><pre name="code" class="cpp">#include<stdio.h>
int a,b;
int main()
{
scanf("%d",&a);
while(a--)
{
scanf("%d",&b);
int n=1;
while(b>n)
{
b-=n;
n++;
}
if(b%9==0)
printf("9\n");
else
printf("%d\n",b%9);
}
return 0;
}


                                            
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: