您的位置:首页 > 其它

小希的迷宫(并查集问题)

2016-01-22 19:48 330 查看
小希的迷宫
Time Limit:1000MS Memory Limit:32768KB 64bit IO Format:%I64d & %I64u
Submit Status

Description

上次Gardon的迷宫城堡小希玩了很久(见Problem B),现在她也想设计一个迷宫让Gardon来走。但是她设计迷宫的思路不一样,首先她认为所有的通道都应该是双向连通的,就是说如果有一个通道连通了房间A和B,那么既可以通过它从房间A走到房间B,也可以通过它从房间B走到房间A,为了提高难度,小希希望任意两个房间有且仅有一条路径可以相通(除非走了回头路)。小希现在把她的设计图给你,让你帮忙判断她的设计图是否符合她的设计思路。比如下面的例子,前两个是符合条件的,但是最后一个却有两种方法从5到达8。



Input

输入包含多组数据,每组数据是一个以0 0结尾的整数对列表,表示了一条通道连接的两个房间的编号。房间的编号至少为1,且不超过100000。每两组数据之间有一个空行。

整个文件以两个-1结尾。

Output

对于输入的每一组数据,输出仅包括一行。如果该迷宫符合小希的思路,那么输出"Yes",否则输出"No"。

Sample Input

6 8  5 3  5 2  6 4
5 6  0 0

8 1  7 3  6 2  8 9  7 5
7 4  7 8  7 6  0 0

3 8  6 8  6 4
5 3  5 6  5 2  0 0

-1 -1


Sample Output

Yes
Yes
No


#include<iostream>

#include<stdio.h>

#include<string.h>

using namespace std;

const int max_num=100005;

typedef struct

{

int num,root,in; //,,入du

}Node;

Node node[max_num];

void Init()

{

for(int i=0;i<max_num;i++)

{

node[i].num=0;

node[i].root=i;

node[i].in=0;

}

}

int Find_root(int x)

{

if(node[x].root!=x)

return node[x].root=Find_root(node[x].root);

return node[x].root;

}

void join(int x,int y)

{

int fx=Find_root(x),fy=Find_root(y);

if(fx!=fy)

node[fy].root=fx;

}

int main()

{

int a,b;

bool flag=true;

Init();

while(scanf("%d%d",&a,&b)!=EOF&&a!=-1&&b!=-1)

{

if(!flag&&a!=0&&b!=0)continue;

if(a==0&&b==0)

{

int root_num=0;

for(int i=1;i<max_num;i++)

{

if(node[i].num&&Find_root(i)==i)

root_num++;

if(node[i].in>1)

{

flag=false;

break;

}

}

if(root_num>1)

flag=false;

if(flag)

printf("Yes\n");

else

printf("No\n");

flag=true;

Init();

continue;

}

if((a!=b&&Find_root(a)==Find_root(b))||a==b)

flag=false;

else

{

node[a].num=1;

node[b].num=1;

node[b].in++;

join(a,b);

}

}

return 0;

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: