您的位置:首页 > 其它

HDU1272 小希的迷宫(并查集+数据坑)

2016-01-19 20:29 246 查看
小希的迷宫

Time Limit:1000MS Memory Limit:32768KB 64bit IO Format:%I64d & %I64u

Submit

Status

Practice

HDU 1272

Description

上次Gardon的迷宫城堡小希玩了很久(见Problem B),现在她也想设计一个迷宫让Gardon来走。但是她设计迷宫的思路不一样,首先她认为所有的通道都应该是双向连通的,就是说如果有一个通道连通了房间A和B,那么既可以通过它从房间A走到房间B,也可以通过它从房间B走到房间A,为了提高难度,小希希望任意两个房间有且仅有一条路径可以相通(除非走了回头路)。小希现在把她的设计图给你,让你帮忙判断她的设计图是否符合她的设计思路。比如下面的例子,前两个是符合条件的,但是最后一个却有两种方法从5到达8。

Input

输入包含多组数据,每组数据是一个以0 0结尾的整数对列表,表示了一条通道连接的两个房间的编号。房间的编号至少为1,且不超过100000。每两组数据之间有一个空行。

整个文件以两个-1结尾。

Output

对于输入的每一组数据,输出仅包括一行。如果该迷宫符合小希的思路,那么输出”Yes”,否则输出”No”。

Sample Input

6 8 5 3 5 2 6 4

5 6 0 0

8 1 7 3 6 2 8 9 7 5

7 4 7 8 7 6 0 0

3 8 6 8 6 4

5 3 5 6 5 2 0 0

-1 -1

Sample Output

Yes

Yes

No

分析:

并查集判断连通块和环。如果最后不只一个人的父亲是自己那么 就说明有多个连通块。如果即将并入的这个人已经在同一个集合里了,那么有环。

坑点:

1。数据会有5 5 这种自己指向自己的。如果不做特判直接修改的话,就会导致它的父亲变成自己。

2。有连着多组case 只有 0 0 这样的数据。如果读入姿势不正确的话,很可能就会少输出几组答案like me=-=。

//  Created by ZYD in 2015.
//  Copyright (c) 2015 ZYD. All rights reserved.
//

#include <cstdio>
#include <cstdlib>
#include <iostream>
#include <algorithm>
#include <cstring>
#include <climits>
#include <string>
#include <vector>
#include <cmath>
#include <stack>
#include <queue>
#include <set>
#include <map>
using namespace std;
#define Size 100000
#define ll long long
#define mk make_pair
#define pb push_back
#define mem(array) memset(array,0,sizeof(array))
typedef pair<int,int> P;
// vector<int> G[100005];
int fa[100005],used[100005];
int x,y;
int find(int x){
int r=x;
while(fa[r]!=r)
r=fa[r];
int i=x,t;
while(fa[i]!=r){        //lujingyasuo
t=fa[i];
fa[i]=r;
i=t;
}
return r;
}
int main()
{
//freopen("in.txt","r",stdin);
while(~scanf("%d %d",&x,&y)&& x!=-1 && y!=-1){

for(int i=1;i<=100000;i++)
fa[i]=i;
mem(used);
// for(int i=1;i<=1000;i++) cout<<used[i];
int flag=0;
fa[x]=y;
used[x]=1;
used[y]=1;
if(x==0 && y==0 ) {printf("Yes\n");continue;}
while(~scanf("%d %d",&x,&y) && x!=0 && y!=0)
{
used[x]=1;used[y]=1;
// if(x==y) continue;
if(flag==1) continue;
int t1=find(x);
int t2=find(y);
if(t1==t2 && x!=y) flag=1;
else {
fa[t1]=t2;
}
}
if(flag==1) {printf("No\n");continue;}
int tot=0;
for(int i=1;i<=100000;i++)
if(used[i]==1 && fa[i]==i)
tot++;
if(tot>1) printf("No\n");
else printf("Yes\n");

// else printf("Yes\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: