您的位置:首页 > 产品设计 > UI/UE

Buildings

2016-01-13 20:25 363 查看
Problem Description

We divide the HZNU Campus into N*M grids. As you can see from the picture below, the green grids represent the buidings. Given the size of the HZNU Campus, and the color of each grid, you should count how many green grids in the N*M grids.



 
Input

Standard input will contain multiple test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow. 

The first line of each test case contains two integers n and m(1<=n,m<=100), the size of the campus. Then follow n lines, each line containing m integers. The j-th integer in the i-th line is the color of that grid, 0 stands for white color, while 1 stands
for green.
 
Output

            Results should be directed to standard output. For each case, output an integers T, the total green grids in the N*M size campus.
 
Sample Input

2
2 2
1 1
0 0
3 3
1 0 1
0 0 1
1 1 0


 
Sample Output

2
5


 
 
Source

2008 HZNU Programming Contest
#include <iostream>
#include <stdio.h>

using namespace std;

int main(){
int T;
cin >> T;
while (T--){
int N, M;
int num;
cin >> N >> M;
int count = 0;
for (int i = 0; i < N; i++){
for (int j = 0; j < M; j++){
cin >> num;
if (num == 1){
count++;
}
}
}
cout << count << endl;
}

return 0;

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: