您的位置:首页 > 其它

【POJ】1611 - The Suspects(并查集)

2016-01-13 12:24 513 查看
The Suspects

Time Limit: 1000MSMemory Limit: 20000K
Total Submissions: 29202Accepted: 14223
Description

Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. To minimize transmission to others, the best strategy is to separate the suspects from others.

In the Not-Spreading-Your-Sickness University (NSYSU), there are many student groups. Students in the same group intercommunicate with each other frequently, and a student may join several groups. To prevent the possible transmissions of SARS, the NSYSU collects
the member lists of all student groups, and makes the following rule in their standard operation procedure (SOP).

Once a member in a group is a suspect, all members in the group are suspects.

However, they find that it is not easy to identify all the suspects when a student is recognized as a suspect. Your job is to write a program which finds all the suspects.
Input

The input file contains several cases. Each test case begins with two integers n and m in a line, where n is the number of students, and m is the number of groups. You may assume that 0 < n <= 30000 and 0 <= m <= 500. Every student is numbered by a unique integer
between 0 and n−1, and initially student 0 is recognized as a suspect in all the cases. This line is followed by m member lists of the groups, one line per group. Each line begins with an integer k by itself representing the number of members in the group.
Following the number of members, there are k integers representing the students in this group. All the integers in a line are separated by at least one space.

A case with n = 0 and m = 0 indicates the end of the input, and need not be processed.
Output

For each case, output the number of suspects in one line.
Sample Input
100 4
2 1 2
5 10 13 11 12 14
2 0 1
2 99 2
200 2
1 5
5 1 2 3 4 5
1 0
0 0

Sample Output
4
1
1

Source

Asia Kaohsiung 2003

并查集的题,需要路径压缩,最后找到0所在树的根,然后找所有根为此的树枝。

代码如下:

#include <stdio.h>
int a[30011];
int ta[30011];
int find(int x)
{
	int r=x;
	while (r!=a[r])
		r=a[r];
	int j=x;
	int t;
	while (a[j]!=r)		//路径压缩(此题需要这个步骤,根据代码自己理解理解吧,不需要死记) 
	{
		t=a[j];
		a[j]=r;
		j=t;
	}
	return r;
}
void join(int x,int y)
{
	int fx,fy;
	fx=find(x);
	fy=find(y);
	if (fx!=fy)
		a[fx]=fy;
}
int main()
{
	int n,m;		//学生数、团体数
	int tn;		//每个团体的人数 
	int t;
	int ans;
	int root;
	while (scanf ("%d %d",&n,&m) && (n||m))
	{
		//首先初始化
		for (int i=0;i<n;i++)
		{
			a[i]=i;
		}
		for (int i=1;i<=m;i++)
		{
			scanf ("%d",&tn);
			for (int j=0;j<tn;j++)
			{
				scanf ("%d",&ta[j]);
			}
			if (tn>=2)		//依次建立树 
			{
				for (int j=1;j<tn;j++)
				{
					join(ta[j],ta[j-1]);
				}
			}
		}
		root=find(a[0]);		//0的根 
		ans=0;
		for (int i=0;i<n;i++)
		{
			if (find(a[i])==root)		//
				ans++;
		}
		printf ("%d\n",ans);
	}
	return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: