您的位置:首页 > 产品设计 > UI/UE

HDU 1005 Number Sequence

2016-01-12 17:15 543 查看
我就在想到底有没有循环节,最后我决定,本题目是有循环节的,因为只要出现两个相邻的数值相同,那么他就会重置f(n)的值进入循环,至于是不是1,是不能确定的。如果出现5和5相邻,是不是就从5开始循环了 ,这 也是确定的。这题目真是有点乱。原解释矩阵快速幂。不过还搞不懂,加油。

[align=left]Problem Description[/align]
A number sequence is defined as follows:

f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.

Given A, B, and n, you are to calculate the value of f(n).

[align=left]Input[/align]
The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.

[align=left]Output[/align]
For each test case, print the value of f(n) on a single line.

[align=left]Sample Input[/align]

1 1 3
1 2 10
0 0 0


[align=left]Sample Output[/align]

2
5


代码:

#include<stdio.h>
#include<iostream>

using namespace std;

int a[10005];
int A, B, n;
int main()
{
a[1] = a[2] = 1;
while(scanf("%d%d%d", &A, &B, &n), A || B || n)
{
int i;
for(i=3; i<10000; i++)
{
a[i] = (A*a[i-1] + B*a[i-2]) % 7;
if(a[i] == 1 && a[i-1] == 1)
break;
}
n = n % (i-2);
a[0] = a[i-2];
cout<<a
<<endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: