您的位置:首页 > 理论基础 > 计算机网络

nyoj 223 Drainage Ditches 【网络流&&最大流】

2016-01-11 20:59 423 查看


Drainage Ditches

时间限制:1000 ms | 内存限制:65535 KB

难度:4

描述 Every time it rains on Farmer John's fields, a pond forms over Bessie's favorite clover patch. This means that the clover is covered by water for awhile and takes quite a long
time to regrow. Thus, Farmer John has built a set of drainage ditches so that Bessie's clover patch is never covered in water. Instead, the water is drained to a nearby stream. Being an ace engineer, Farmer John has also installed regulators at the beginning
of each ditch, so he can control at what rate water flows into that ditch.

Farmer John knows not only how many gallons of water each ditch can transport per minute but also the exact layout of the ditches, which feed out of the pond and into each other and stream in a potentially complex network.

Given all this information, determine the maximum rate at which water can be transported out of the pond and into the stream. For any given ditch, water flows in only one direction, but there might be a way that water can flow in a circle.

输入The input includes several cases. For each case, the first line contains two space-separated integers, N (0 <= N <= 200) and M (2 <= M <= 200). N is the number of ditches that Farmer John has dug. M is the number of intersections points for those ditches.
Intersection 1 is the pond. Intersection point M is the stream. Each of the following N lines contains three integers, Si, Ei, and Ci. Si and Ei (1 <= Si, Ei <= M) designate the intersections between which this ditch flows. Water will flow through this ditch
from Si to Ei. Ci (0 <= Ci <= 10,000,000) is the maximum rate at which water will flow through the ditch.输出For each case, output a single integer, the maximum rate at which water may emptied from the pond.
样例输入
5 4
1 2 40
1 4 20
2 4 20
2 3 30
3 4 10

样例输出
50


分析:


最大流模版,谨以此记住。


代码:


#include<cstdio>
#include<cstdlib>
#include<algorithm>
#include<queue>
#include<cstring>
#include<stack>
#include<iostream>
#include<vector>
#define mem(x,y) memset(x,y,sizeof(x))
#define SI(x) scanf("%d",&x)
#define O_O(x) while(x--)
using namespace std;

const int maxn=220;
const int INF=0x3f3f3f3f;
int map[maxn][maxn];
int dep[maxn];

int n,m,src,des;

int bfs()
{
queue<int>q;
while(!q.empty())
q.pop();
mem(dep,-1);
dep[src]=0;
q.push(src);
while(!q.empty())
{
int u=q.front();
q.pop();
for(int v=1;v<=m;v++)
if(map[u][v]>0&&dep[v]==-1)
{
dep[v]=dep[u]+1;
q.push(v);
}
}
return dep[des]!=-1;
}

int dfs(int u,int minx)
{
if(u==des)
return minx;
int tmp;
for(int v=1;v<=m;v++)
{
if(map[u][v]>0&&dep[v]==dep[u]+1&&(tmp=dfs(v,min(minx,map[u][v]))))
{
map[u][v]-=tmp;
map[v][u]+=tmp;
return tmp;
}
}
return 0;
}

int dinic()
{
int ans=0,temp;
while(bfs()){
while(1)
{
temp=dfs(1,INF);
if(temp==0)
break;
ans+=temp;
}
}
return ans;
}

int main()
{
while(scanf("%d%d",&n,&m)!=EOF)
{
mem(map,0);
int u,v,w;
for(int i=0;i<n;i++)
{
scanf("%d%d%d",&u,&v,&w);
map[u][v]+=w;
}
src=1,des=m;
printf("%d\n",dinic());
}
return 0;
}

[/code]
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: