您的位置:首页 > 运维架构

poj 3258 River Hopscotch

2016-01-05 10:41 274 查看
Description

Every year the cows hold an event featuring a peculiar version of hopscotch that involves carefully jumping from rock to rock in a river. The excitement takes place on a long, straight river with a rock at the start and another rock at the end, L units away
from the start (1 ≤ L ≤ 1,000,000,000). Along the river between the starting and ending rocks, N (0 ≤ N ≤ 50,000) more rocks appear, each at an integral distance Di from the start (0 < Di < L).

To play the game, each cow in turn starts at the starting rock and tries to reach the finish at the ending rock, jumping only from rock to rock. Of course, less agile cows never make it to the final rock, ending up instead in the river.

Farmer John is proud of his cows and watches this event each year. But as time goes by, he tires of watching the timid cows of the other farmers limp across the short distances between rocks placed too closely together. He plans to remove several rocks in
order to increase the shortest distance a cow will have to jump to reach the end. He knows he cannot remove the starting and ending rocks, but he calculates that he has enough resources to remove up to M rocks (0 ≤ M ≤ N).

FJ wants to know exactly how much he can increase the shortest distance *before* he starts removing the rocks. Help Farmer John determine the greatest possible shortest distance a cow has to jump after removing the optimal set of M rocks.

Input

Line 1: Three space-separated integers: L, N, and M

Lines 2..N+1: Each line contains a single integer indicating how far some rock is away from the starting rock. No two rocks share the same position.

Output

Line 1: A single integer that is the maximum of the shortest distance a cow has to jump after removing M rocks

Sample Input

25 5 2

2

14

11

21

17

Sample Output

4

Hint

Before removing any rocks, the shortest jump was a jump of 2 from 0 (the start) to 2. After removing the rocks at 2 and 14, the shortest required jump is a jump of 4 (from 17 to 21 or from 21 to 25).

 

  这题好恶心。。。。巨恶心。。。。

  二分,但是要很细心的处理边界。用二分找距离,然后判断这个距离是否符合要求,如果符合继续二分看能否找到更大的。。。如果符合继续二分看能否找到更小的符合要求。。。。。。

```

#include <iostream>

#include <cstdio>

#include <algorithm>

using namespace std;

int a[50005]={0};

int l,n,m;

bool judge(int dis)

{

    int pos=0,cur;

    int N=n+1-m;

    for(int i=0;i<N;i++)

    {

        cur=pos+1;

        while(cur<=n+1&&a[cur]-a[pos]<dis)

        {

            cur++;

        }

        pos=cur;

        if(cur>n+1)

            return false;

    }

    return true;

}

int main()

{

    while(scanf("%d%d%d",&l,&n,&m)!=EOF)

    {

        a[0]=0;

        for(int i=1;i<=n;i++ )

        {

            scanf("%d",&a[i]);

        }

        if(n==m)

        {

            cout<<l<<endl;

            continue;

        }

        sort(a,a+n+1);

        a[n+1]=l;

        int L=0,R=l,mid;

        while(R-L>1)

        {

            mid=(R+L)/2;

            if(judge(mid)==true)

            {

                L=mid;

            }

            else

            {

                R=mid;

            }

        }

        cout<<L<<endl;

    }

}

```

 
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: