您的位置:首页 > 其它

poj1797

2016-01-04 19:07 183 查看
Time Limit: 3000MS Memory Limit: 30000K
Total Submissions: 26357 Accepted: 7011
Description

Background 

Hugo Heavy is happy. After the breakdown of the Cargolifter project he can now expand business. But he needs a clever man who tells him whether there really is a way from the place his customer has build his giant steel crane to the place where it is needed
on which all streets can carry the weight. 

Fortunately he already has a plan of the city with all streets and bridges and all the allowed weights.Unfortunately he has no idea how to find the the maximum weight capacity in order to tell his customer how heavy the crane may become. But you surely know. 

Problem 

You are given the plan of the city, described by the streets (with weight limits) between the crossings, which are numbered from 1 to n. Your task is to find the maximum weight that can be transported from crossing 1 (Hugo's place) to crossing n (the customer's
place). You may assume that there is at least one path. All streets can be travelled in both directions.
Input

The first line contains the number of scenarios (city plans). For each city the number n of street crossings (1 <= n <= 1000) and number m of streets are given on the first line. The following m lines contain triples of integers specifying start and end crossing
of the street and the maximum allowed weight, which is positive and not larger than 1000000. There will be at most one street between each pair of crossings.
Output

The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Then print a single line containing the maximum allowed weight that Hugo can transport to the customer. Terminate the output for
the scenario with a blank line.
Sample Input
1
3 3
1 2 3
1 3 4
2 3 5

Sample Output
Scenario #1:
4

从城市1到城市n运输物品,途中需要经过一些路,路的承重不同,问1~n 最大可以运输物品重量
最后 记得换行再换行 #include <iostream>
#include <string.h>
#include <stdio.h>
#include <math.h>
using namespace std;
const int maxn=1005;
const int inf=1e9;
int map[maxn][maxn];
bool used[maxn];
int cost[maxn];
int n;
int prim()
{
memset(used,false,sizeof(used));

int ans=inf;
for(int i=1; i<=n; i++)
cost[i]=map[1][i];///集合cost
used[1]=true;
for(int i=1; i<n; i++)///n个点,n-1边
{
int maxc=-inf;
int k=-1;
for(int j=2; j<=n; j++)
{
if(!used[j]&&maxc<cost[j])
{
maxc=cost[j];
k=j;
}
}
ans=min(ans,maxc);
used[k]=true;
if(k==n)///找到B
break;
for(int j=1; j<=n; j++)
{
if(map[k][j]>cost[j]&&!used[j])
{
cost[j]=map[k][j];
}
}
}
return ans;
}
int main()
{
int t,x,y,cost,m;
cin>>t;
for(int i=1; i<=t; i++)
{
scanf("%d%d",&n,&m);
memset(map,0,sizeof(map));
for(int j=0; j<m; j++)
{
scanf("%d%d%d",&x,&y,&cost);
map[x][y]=cost;
map[y][x]=cost;
}
printf("Scenario #%d:\n%d\n\n",i,prim());
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: