您的位置:首页 > 产品设计 > UI/UE

HDU - 5036 Operation the Sequence

2016-01-03 19:16 639 查看
Problem Description

You have an array consisting of n integers: a1=1,a2=2,a3=3,…,an=n.
Then give you m operators, you should process all the operators in order. Each operator is one of four types:

Type1: O 1 call fun1();

Type2: O 2 call fun2();

Type3: O 3 call fun3();

Type4: Q i query current value of a[i], this operator will have at most 50.

Global Variables: a[1…n],b[1…n];

fun1() {

index=1;

for(i=1; i<=n; i +=2)

b[index++]=a[i];

for(i=2; i<=n; i +=2)

b[index++]=a[i];

for(i=1; i<=n; ++i)

a[i]=b[i];

}

fun2() {

L = 1;R = n;

while(L<R) {

Swap(a[L], a[R]);

++L;--R;

}

}

fun3() {

for(i=1; i<=n; ++i)

a[i]=a[i]*a[i];

}

Input

The first line in the input file is an integer T(1≤T≤20),
indicating the number of test cases.

The first line of each test case contains two integer n(0<n≤100000), m(0<m≤100000).

Then m lines follow, each line represent an operator above.

Output

For each test case, output the query values, the values may be so large, you just output the values mod 1000000007(1e9+7).

Sample Input

1
3 5
O 1
O 2
Q 1
O 3
Q 1


Sample Output

2
4


Source

BestCoder Round #13

题意:O1操作是将奇数位置的下标放到前面。偶数放到后面,O2是将序列翻转,O3是序列平方,求每次Q下标的数是多少
思路:注意到查询次数不超过50次。那么能够从查询位置逆回去操作。就能够发现它在最初序列的位置,再逆回去就可以求得当前查询的值,对于一组数据复杂度约为O(50*n)。
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
typedef __int64 ll;
//typedef long long ll;
using namespace std;
const int maxn = 100005;
const int mod = 1000000007;

int n, m;
int O[maxn];
ll num[maxn];

int main() {
int t;
scanf("%d", &t);
while (t--) {
scanf("%d%d", &n, &m);
char str[10];
int op, cnt = 0;
int sum = 0;
for (int i = 0; i < m; i++) {
scanf("%s%d", str, &op);
if (str[0] == 'O') {
if (op == 3)
sum++;
else O[cnt++] = op;
}
else {
for (int j = cnt-1; j >= 0; j--) {
int cur = O[j];
if (cur == 1) {
if (n & 1) {
if (op <= n/2 + 1)
op = op * 2 - 1;
else op = (op - n / 2 - 1) * 2;
}
else {
if (op <= n / 2)
op = op * 2 - 1;
else op = (op - n / 2) * 2;
}
}
else if (cur == 2)
op = n - op + 1;
}
ll ans = op;
for (int i = 0; i < sum; i++)
ans = ans * ans % mod;
printf("%I64d\n", ans);
}
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: