您的位置:首页 > 产品设计 > UI/UE

poj 2533_Longest Ordered Subsequence

2016-01-03 11:11 393 查看
Longest Ordered Subsequence

Time Limit: 2000MSMemory Limit: 65536K
Total Submissions: 41757Accepted: 18384
Description

A numeric sequence of ai is ordered if a1 < a2 < ... < aN. Let the subsequence of the given numeric sequence (a1, a2, ..., aN)
be any sequence (ai1, ai2, ..., aiK), where 1 <= i1 < i2 < ... < iK <= N. For example, sequence
(1, 7, 3, 5, 9, 4, 8) has ordered subsequences, e. g., (1, 7), (3, 4, 8) and many others. All longest ordered subsequences are of length 4, e. g., (1, 3, 5, 8).

Your program, when given the numeric sequence, must find the length of its longest ordered subsequence.
Input

The first line of input file contains the length of sequence N. The second line contains the elements of sequence - N integers in the range from 0 to 10000 each, separated by spaces. 1 <= N <= 1000
Output

Output file must contain a single integer - the length of the longest ordered subsequence of the given sequence.
Sample Input
7
1 7 3 5 9 4 8

Sample Output
4

#include <iostream>
#include <cstring>
#include <cstdio>
#include <algorithm>
using namespace std;
int num[1005];
int dp[1005];
int main()
{
int n;
while(~scanf("%d",&n)) {
for(int i = 0; i < n; i++) {
scanf("%d",&num[i]);
}
dp[0] = 1;
for(int i = 1; i < n; i++) {
dp[i] = 1;
for(int j = 0; j < i; j++) {
if(num[i] > num[j] && dp[j] + 1 > dp[i]) {
dp[i] = dp[j] + 1;
}
}
}
int dp_max = 0;
for(int i = 0; i < n; i++) {
if(dp[i] > dp_max) {
dp_max = dp[i];
}
}
printf("%d\n",dp_max);
}
return 0;
}

求最长递增子序列

/**
//dp   O(n2)
#include <stdio.h>
#include <stdlib.h>

int num[1005];
int dp[1005];

int main() {
int n;
scanf("%d",&n);
for(int i = 0; i < n; i++) {
scanf("%d",&num[i]);
}
for(int i = 0; i < n; i++) {
dp[i] = 1;
for(int j = 0; j < i; j++) {
if(num[i] > num[j] && dp[j]+1 > dp[i]) {
dp[i] = dp[j] + 1;
}
}
}
int maxn = 0;
for(int i = 0; i < n; i++) {
if(dp[i] > maxn) maxn = dp[i];
}
printf("%d\n",maxn);
}
**/
// O(nlogn)
#include <stdio.h>
#include <stdlib.h>
#include <string.h>

int num[1005];
int d[1005];
int len;

int BiSearch(int *num, int len, int w) {
int left = 0, right = len - 1;
int mid;
while (left <= right) {
mid = left + (right-left)/2;
if (d[mid] > w)
right = mid - 1;
else if (d[mid] < w)
left = mid + 1;
else
return mid;
}
return left;//数组b中不存在该元素,则返回该元素应该插入的位置
}
int LIS(int *num, int n) {
len = 1;
d[0] = num[0];
int pos = 0;
for(int i = 1; i < n; i++) {
if(num[i] > d[len-1]) {
d[len] = num[i];
len++;
}
else {
pos = BiSearch(d, len, num[i]);
d[pos] = num[i];
}
}
return len;
}

int main() {
int n;
scanf("%d",&n);
for(int i = 0; i < n; i++) {
scanf("%d",&num[i]);
}
printf("%d\n",LIS(num, n));
return 0;
}
/*
15
1 2 5 -1 3 6 5 4 47 1 2 5 7 8 10
*/


O(NlgN)算法

假设存在一个序列d[1..9] ={ 2,1 ,5 ,3 ,6,4, 8 ,9, 7},可以看出来它的LIS长度为5。
下面一步一步试着找出它。
我们定义一个序列B,然后令 i = 1 to 9 逐个考察这个序列。
此外,我们用一个变量Len来记录现在最长算到多少了

首先,把d[1]有序地放到B里,令B[1] = 2,就是说当只有1一个数字2的时候,长度为1的LIS的最小末尾是2。这时Len=1

然后,把d[2]有序地放到B里,令B[1] = 1,就是说长度为1的LIS的最小末尾是1,d[1]=2已经没用了,很容易理解吧。这时Len=1

接着,d[3] = 5,d[3]>B[1],所以令B[1+1]=B[2]=d[3]=5,就是说长度为2的LIS的最小末尾是5,很容易理解吧。这时候B[1..2] = 1, 5,Len=2

再来,d[4] = 3,它正好加在1,5之间,放在1的位置显然不合适,因为1小于3,长度为1的LIS最小末尾应该是1,这样很容易推知,长度为2的LIS最小末尾是3,于是可以把5淘汰掉,这时候B[1..2] = 1, 3,Len = 2

继续,d[5] = 6,它在3后面,因为B[2] = 3, 而6在3后面,于是很容易可以推知B[3] = 6, 这时B[1..3] = 1, 3, 6,还是很容易理解吧? Len = 3 了噢。

第6个, d[6] = 4,你看它在3和6之间,于是我们就可以把6替换掉,得到B[3] = 4。B[1..3] = 1, 3, 4, Len继续等于3

第7个, d[7] = 8,它很大,比4大,嗯。于是B[4] = 8。Len变成4了

第8个, d[8] = 9,得到B[5] = 9,嗯。Len继续增大,到5了。

最后一个, d[9] = 7,它在B[3] = 4和B[4] = 8之间,所以我们知道,最新的B[4] =7,B[1..5] = 1, 3, 4, 7, 9,Len = 5。

于是我们知道了LIS的长度为5。

注意,这个1,3,4,7,9不是LIS,它只是存储的对应长度LIS的最小末尾。有了这个末尾,我们就可以一个一个地插入数据。虽然最后一个d[9] = 7更新进去对于这组数据没有什么意义,但是如果后面再出现两个数字 8 和 9,那么就可以把8更新到d[5], 9更新到d[6],得出LIS的长度为6。

然后应该发现一件事情了:在B中插入数据是有序的,而且是进行替换而不需要挪动——也就是说,我们可以使用二分查找,将每一个数字的插入时间优化到O(logN)~~~~~于是算法的时间复杂度就降低到了O(NlogN)~!
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: