您的位置:首页 > 其它

Robots(Poj1548)(贪心)

2016-01-01 16:44 393 查看
Robots

Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 4080 Accepted: 1870
Description

Your company provides robots that can be used to pick up litter from fields after sporting events and concerts. Before robots are assigned to a job, an aerial photograph of the field is marked with a grid. Each location in the grid that contains garbage is
marked. All robots begin in the Northwest corner and end their movement in the Southeast corner. A robot can only move in two directions, either to the East or South. Upon entering a cell that contains garbage, the robot will pick it up before proceeding.
Once a robot reaches its destination at the Southeast corner it cannot be repositioned or reused. Since your expenses are directly proportional to the number of robots used for a particular job, you are interested in finding the minimum number of robots that
can clean a given field. For example, consider the field map shown in Figure 1 with rows and columns numbered as shown and garbage locations marked with a 'G'. In this scheme, all robots will begin in location 1,1 and end in location 6, 7. 


 

Figure 1 - A Field Map

Figure 2 below shows two possible solutions, the second of which is preferable since it uses two robots rather than three. 


 

Figure 2 - Two Possible Solutions

Your task is to create a program that will determine the minimum number of robots needed to pick up all the garbage from a field. 

Input

The input consists of one or more field maps followed by a line containing -1 -1 to signal the end of the input data. A field map consists of one or more lines, each containing one garbage location, followed by a line containing 0 0 to signal the end of the
map. Each garbage location consists of two integers, the row and column, separated by a single space. The rows and columns are numbered as shown in Figure 1. The garbage locations will be given in row-major order. No single field map will have more than 24
rows and 24 columns. The sample input below shows an input file with two field maps. The first is the field map from Figure 1.
Output

The output will consist of a single line for each field map containing the minimum number of robots needed to clean the corresponding field.
Sample Input
1 2
1 4
2 4
2 6
4 4
4 7
6 6
0 0
1 1
2 2
4 4
0 0
-1 -1

Sample Output
2
1

Source

Mid-Central USA 2003

数组开大点,不然一直RE。 思路:只要右边有垃圾就往右走,没有就往下走~

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
struct st
{
int l,r,flag;
}s[1000];
int cmp(st x,st y)
{
if(x.l!=y.l)
return x.l<y.l;
return x.r<y.r;
}
int main()
{
int i,j,a,b,n,ans;
while(scanf("%d%d",&a,&b)&&(a!=-1&&b!=-1))
{
ans=i=0;
while(a&&b)
{
s[i].l=a;
s[i].r=b;
s[i].flag=0;
scanf("%d%d",&a,&b);
i++;
}
n=i;
sort(s,s+n,cmp);
for(i=0;i<n;i++)
{
if(!s[i].flag)
{
s[i].flag=1;
ans++;
a=s[i].r;
for(j=i+1;j<n;j++)
{
if(!s[j].flag&&s[j].r>=a)
{
s[j].flag=1;
a=s[j].r;
}
}
}
}
printf("%d\n",ans);
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: