您的位置:首页 > 其它

第六届福建省大学生程序设计竞赛 Problem J RunningMan【数学】

2015-12-27 16:26 375 查看
Problem J RunningMan


Accept: 123 Submit: 551
Time Limit: 1000 mSec Memory Limit : 32768 KB



Problem Description

ZB loves watching RunningMan! There's a game in RunningMan called 100 vs 100.

There are two teams, each of many people. There are 3 rounds of fighting, in each round the two teams send some people to fight. In each round, whichever team sends more people wins, and if the two teams send the same amount of people, RunningMan team wins.
Each person can be sent out to only one round. The team wins 2 rounds win the whole game. Note, the arrangement of the fighter in three rounds must be decided before the whole game starts.

We know that there are N people on the RunningMan team, and that there are M people on the opposite team. Now zb wants to know whether there exists an arrangement of people for the RunningMan team so that they can always win, no matter how the opposite team
arrange their people.



Input

The first line contains an integer T, meaning the number of the cases. 1 <= T <= 50.

For each test case, there's one line consists of two integers N and M. (1 <= N, M <= 10^9).



Output

For each test case, Output "Yes" if there exists an arrangement of people so that the RunningMan team can always win. "No" if there isn't such an arrangement. (Without the quotation marks.)



Sample Input

2
100 100
200 100



Sample Output

No
Yes



Hint

In the second example, the RunningMan team can arrange 60, 60, 80 people for the three rounds. No matter how the opposite team arrange their 100 people, they cannot win.

解题思路:

几组数据可以得出,只要其中的最少的两组的人数大于另外一队则可以输出Yes。

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int main()
{
int T;
scanf("%d",&T);
while(T--)
{
int a,b;
scanf("%d%d",&a,&b);
int LL;
int LLL;
LLL=a%3;
LL=a/3;
if(LLL==0)
{
if(2*(LL+1)>b)
{
printf("Yes\n");
}
else
{
printf("No\n");
}
}
else if(LLL==1)
{
if(2*(LL+1)>b)
{
printf("Yes\n");
}
else
{
printf("No\n");
}
}
else if(LLL==2)
{
if(2*(LL+1)+1>b)
{
printf("Yes\n");
}
else
{
printf("No\n");
}
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: