您的位置:首页 > 其它

hdu 5600 N bulbs

2015-12-27 12:28 218 查看

N bulbs

[b]Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)

Total Submission(s): 241    Accepted Submission(s): 132
[/b]

[align=left]Problem Description[/align]
N bulbs are in a row from left to right,some are on, and some are off.The first bulb is the most left one. And the last one is the most right one.they are numbered from 1 to n,from left to right.

in order to save electricity, you should turn off all the lights, but you're lazy.

coincidentally,a passing bear children paper(bear children paper means the naughty boy), who want to pass here from the first light bulb to the last one and leave.

he starts from the first light and just can get to the adjacent one at one step.

But after all,the bear children paper is just a bear children paper. after leaving a light bulb to the next one, he must touch the switch, which will change the status of the light.

your task is answer whether it's possible or not to finishing turning off all the lights, and make bear children paper also reach the last light bulb and then leave at the same time.
 

[align=left]Input[/align]
The first line of the input file contains an integer T, which indicates the number of test cases.

For each test case, there are 2 lines.

The first line of each test case contains 1 integers n.

In the following line contains a 01 sequence, 0 means off and 1 means on.

* 1≤T≤10

* 1≤N≤1000000
 

[align=left]Output[/align]
There should be exactly T lines in the output file.

The i-th line should only contain "YES" or "NO" to answer if it's possible to finish.
 

[align=left]Sample Input[/align]

1
5
1 0 0 0 0

 

[align=left]Sample Output[/align]

YES

HintChild's path is: 123234545
all switchs are touched twice except the first one.

 

[align=left]Source[/align]
BestCoder Round #67 (div.2)
 

好吧,依次把所有的数变成0,到最后一个如果是1就可以关闭所有的灯,否则就不可以

#include <iostream>
#include <cstdio>

using namespace std;

int a[1000000],n;

int dfs()
{
for(int i = 0;i<n-1;i++)
{
if(!a[i])
{
a[i+1] = 1-a[i+1];
}
}
return a[n-1];
}

int main()
{
int T;
scanf("%d",&T);
while(T--)
{
scanf("%d",&n);
for(int i = 0;i<n;i++)
scanf("%d",&a[i]);
if(dfs())
printf("YES\n");
else
printf("NO\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息