您的位置:首页 > 其它

LA 3644 (并查集)

2015-12-22 22:26 357 查看
A secret service developed a new kind of explosive that attain its volatile property only when a specific

association of products occurs. Each product is a mix of two different simple compounds, to which we

call a binding pair. If N > 2, then mixing N different binding pairs containing N simple compounds

creates a powerful explosive. For example, the binding pairs A+B, B+C, A+C (three pairs, three

compounds) result in an explosive, while A+B, B+C, A+D (three pairs, four compounds) does not.

You are not a secret agent but only a guy in a delivery agency with one dangerous problem: receive

binding pairs in sequential order and place them in a cargo ship. However, you must avoid placing in

the same room an explosive association. So, after placing a set of pairs, if you receive one pair that

might produce an explosion with some of the pairs already in stock, you must refuse it, otherwise, you

must accept it.

An example. Lets assume you receive the following sequence: A+B, G+B, D+F, A+E, E+G,

F+H. You would accept the first four pairs but then refuse E+G since it would be possible to make the

following explosive with the previous pairs: A+B, G+B, A+E, E+G (4 pairs with 4 simple compounds).

Finally, you would accept the last pair, F+H.

Compute the number of refusals given a sequence of binding pairs.

Input

The input will contain several test cases, each of them as described below. Consecutive

test cases are separated by a single blank line.

Instead of letters we will use integers to represent compounds. The input contains several lines.

Each line (except the last) consists of two integers (each integer lies between 0 and 105

) separated by

a single space, representing a binding pair.

Each test case ends in a line with the number ‘-1’. You may assume that no repeated binding pairs

appears in the input.

Output

For each test case, the output must follow the description below.

A single line with the number of refusals.

Sample Input

1 2

3 4

3 5

3 1

2 3

4 1

2 6

6 5

-1

Sample Output
3

题意:简单来说就是判断这些点有没有构成环,如果有就答案+1.

题解:使用并查集维护点信息,千万不要想着使用Floyd判断有没有环,这些点的个数都没有明确给出。这里我想的是使用按秩合并(按权值合并),其实不是用按秩合并也是可以的,只要每次都找到根,合并就可以了。自己想多了。。。。。。。

#include<iostream>
#include<cstdio>
#include<map>
#include<algorithm>
#include<string>
#include<cmath>
#include<vector>
#include<queue>
#include<deque>
#include<cstring>
#include<set>
#include<vector>
using namespace std;
#define LL long long
#define N 100005
int fa
;
int Rank
;
inline void init()
{
for(int i=0;i<N;i++)
{
fa[i]=i;
Rank[i]=1;
}
}
int find(int x)
{
return x==fa[x]?x:fa[x]=find(fa[x]);
}
int unio(int x,int y)
{
x=find(x);
y=find(y);
if(x==y)
{
return 1;
}
else
{
if(Rank[x]>Rank[y])
{
fa[y]=x;
Rank[x]+=Rank[y];
}
else
{
fa[x]=y;
Rank[y]+=Rank[x];
}
return 0;
}
}
int main()
{
#ifdef CDZSC
freopen("i.txt","r",stdin);
#endif
init();
int ans=0;
int a,b;
while(~scanf("%d",&a))
{
if(a==-1)
{
printf("%d\n",ans);
init();
ans=0;
}
else
{
scanf("%d",&b);
ans+=unio(a,b);
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: