您的位置:首页 > 其它

poj 2387 Til the Cows Come Home(最短路)

2015-12-22 19:41 393 查看
Til the Cows Come Home

Description

Bessie is out in the field and wants to get back to the barn to get as much sleep as possible before Farmer John wakes her for the morning milking. Bessie needs her beauty sleep, so she wants to get back as quickly as possible.

Farmer John's field has N (2 <= N <= 1000) landmarks in it, uniquely numbered 1..N. Landmark 1 is the barn; the apple tree grove in which Bessie stands all day is landmark N. Cows travel in the field using T (1 <= T <= 2000) bidirectional cow-trails of various
lengths between the landmarks. Bessie is not confident of her navigation ability, so she always stays on a trail from its start to its end once she starts it.

Given the trails between the landmarks, determine the minimum distance Bessie must walk to get back to the barn. It is guaranteed that some such route exists.

Input

* Line 1: Two integers: T and N

* Lines 2..T+1: Each line describes a trail as three space-separated integers. The first two integers are the landmarks between which the trail travels. The third integer is the length of the trail, range 1..100.

Output

* Line 1: A single integer, the minimum distance that Bessie must travel to get from landmark N to landmark 1.

Sample Input

5 5

1 2 20

2 3 30

3 4 20

4 5 20

1 5 100

Sample Output

90

solution:

裸的dijkstra,但是要注意有重边

#include<cstdio>
#include<algorithm>
#include<cstring>
const int inf = 1e9;
using namespace std;
int dis[1500], map[1500][1500],v[1500];
int n, t;
void dj()
{
for (int i = 1; i <= n; i++)
dis[i] = inf;
dis[1] = 0;
memset(v, 0, sizeof(v));
for (int i = 1; i <= n; i++)
{
int u = -1, minn = inf;
for (int j = 1; j <= n;j++)
if (v[j] == 0 && dis[j] < minn)
{
minn = dis[j]; u = j;
}
v[u] = 1;
for (int j = 1; j <= n; j++)
if (v[j] == 0)dis[j] = min(dis[j], dis[u] + map[u][j]);
}
}
int main()
{
int x, y, z;
scanf("%d%d", &t, &n);
for (int i = 0; i <= 1000; i++)
for (int j = 0; j <= 1000; j++)
map[i][j] = inf;
while (t--)
{
scanf("%d%d%d", &x, &y, &z);
if (z < map[x][y])
{
map[x][y] = map[y][x] = z;
}
}
dj();
printf("%d\n", dis
);
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: