您的位置:首页 > 其它

poj 2229 Sumsets 【完全背包 or 递推】

2015-12-20 12:03 232 查看
Sumsets

Time Limit: 2000MS Memory Limit: 200000K
Total Submissions: 14968 Accepted: 5978
Description

Farmer John commanded his cows to search for different sets of numbers that sum to a given number. The cows use only numbers that are an integer power of 2. Here are the possible sets of numbers that sum to 7: 

1) 1+1+1+1+1+1+1 

2) 1+1+1+1+1+2 

3) 1+1+1+2+2 

4) 1+1+1+4 

5) 1+2+2+2 

6) 1+2+4 

Help FJ count all possible representations for a given integer N (1 <= N <= 1,000,000). 

Input

A single line with a single integer, N.
Output

The number of ways to represent N as the indicated sum. Due to the potential huge size of this number, print only last 9 digits (in base 10 representation).
Sample Input
7

Sample Output
6


题意:给定一个N,只允许使用2的幂次数,问有多少种不同的方案组成N。

首先这道题有一个很好想的思路:裸完全背包

最多20个物品,价值分别为2^0, 2^1, ..., 2^19。

这样直接跑一次完全背包打好表就可以了。 G++可以过,C++过不了。。。

#include <cstdio>
#include <cstring>
#include <cmath>
#include <cstdlib>
#include <algorithm>
#include <queue>
#include <stack>
#include <map>
#include <set>
#include <vector>
#define INF 0x3f3f3f
#define eps 1e-8
#define MAXN (1000000+1)
#define MAXM (100000)
#define Ri(a) scanf("%d", &a)
#define Rl(a) scanf("%lld", &a)
#define Rf(a) scanf("%lf", &a)
#define Rs(a) scanf("%s", a)
#define Pi(a) printf("%d\n", (a))
#define Pf(a) printf("%.2lf\n", (a))
#define Pl(a) printf("%lld\n", (a))
#define Ps(a) printf("%s\n", (a))
#define W(a) while(a--)
#define CLR(a, b) memset(a, (b), sizeof(a))
#define MOD 1000000007
#define LL long long
#define lson o<<1, l, mid
#define rson o<<1|1, mid+1, r
#define ll o<<1
#define rr o<<1|1
using namespace std;
LL dp[MAXN];
int fac[21];
int Pow(int a, int n)
{
int ans = 1;
while(n)
{
ans *= a;
n--;
}
return ans;
}
void getdp()
{
for(int i = 0; i < 20; i++)
fac[i] = Pow(2, i);
dp[0] = 1;
for(int i = 0; i < 20; i++)
for(int j = fac[i]; j < MAXN; j++)
dp[j] = (dp[j] + dp[j-fac[i]])%1000000000;
}
int main()
{
getdp();
int n; Ri(n); Pl(dp
);
return 0;
}


另外一种思路:

两种dp状态推导dp[]。

一、dp[i] = dp[i-1];

二、dp[i] = dp[i-1] + dp[i>>1]。

#include <cstdio>
#include <cstring>
#include <cmath>
#include <cstdlib>
#include <algorithm>
#include <queue>
#include <stack>
#include <map>
#include <set>
#include <vector>
#define INF 0x3f3f3f
#define eps 1e-8
#define MAXN (1000000+1)
#define MAXM (100000)
#define Ri(a) scanf("%d", &a)
#define Rl(a) scanf("%lld", &a)
#define Rf(a) scanf("%lf", &a)
#define Rs(a) scanf("%s", a)
#define Pi(a) printf("%d\n", (a))
#define Pf(a) printf("%.2lf\n", (a))
#define Pl(a) printf("%lld\n", (a))
#define Ps(a) printf("%s\n", (a))
#define W(a) while(a--)
#define CLR(a, b) memset(a, (b), sizeof(a))
#define MOD 1000000007
#define LL long long
#define lson o<<1, l, mid
#define rson o<<1|1, mid+1, r
#define ll o<<1
#define rr o<<1|1
using namespace std;
LL dp[MAXN];
void getdp()
{
dp[0] = 1;
for(int i = 1; i < MAXN; i++)
{
if(i & 1)
dp[i] = dp[i-1];
else
dp[i] = (dp[i-1] + dp[i >> 1]) % 1000000000;
}
}
int main()
{
getdp();
int n; Ri(n); Pl(dp
);
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: