您的位置:首页 > 移动开发 > IOS开发

hdu 1017 A Mathematical Curiosity【枚举+格式】

2015-12-17 18:40 519 查看

A Mathematical Curiosity

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 34091 Accepted Submission(s): 10832

[align=left]Problem Description[/align]
Given two integers n and m, count the number of pairs of integers (a,b) such that 0 < a < b < n and (a^2+b^2 +m)/(ab) is an integer.

This problem contains multiple test cases!

The first line of a multiple input is an integer N, then a blank line followed by N input blocks. Each input block is in the format indicated in the problem description. There is a blank line between input blocks.

The output format consists of N output blocks. There is a blank line between output blocks.

[align=left]Input[/align]
You will be given a number of cases in the input. Each case is specified by a line containing the integers n and m. The end of input is indicated by a case in which n = m = 0. You may assume that 0 < n <= 100.

[align=left]Output[/align]
For each case, print the case number as well as the number of pairs (a,b) satisfying the given property. Print the output for each case on one line in the format as shown below.

[align=left]Sample Input[/align]

1

10 1
20 3
30 4
0 0

[align=left]Sample Output[/align]

Case 1: 2
Case 2: 4
Case 3: 5

除了暴力枚举,好像没别的什么好方法...

而且坑死人的格式,根本就是在欺负英语学的不好的孩子...

#include<stdio.h>
int count(int n,int m)
{
int cnt=0;
for(int a=1;a<n;++a)
{
for(int b=a+1;b<n;++b)
{
if((a*a+b*b+m)%(a*b)==0)
{
++cnt;
}
}
}
return cnt;
}
int main()
{
int t;
//freopen("shuju.txt","r",stdin);
scanf("%d",&t);
for(int i=0;i<t;++i)//t 组样例
{
if(i)//空行控制
{
printf("\n");
}
int n,m,cnt=0;//每次都要从 1 开始统计
while(scanf("%d%d",&n,&m),n|m)
{
printf("Case %d: %d\n",++cnt,count(n,m));
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: