您的位置:首页 > 其它

HDU 2709 DP

2015-12-17 14:58 381 查看

Sumsets

Time Limit: 6000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 1977    Accepted Submission(s): 781


[align=left]Problem Description[/align]
Farmer John commanded his cows to search for different sets of numbers that sum to a given number. The cows use only numbers that are an integer power of 2. Here are the possible sets of numbers that sum to 7:

1) 1+1+1+1+1+1+1

2) 1+1+1+1+1+2

3) 1+1+1+2+2

4) 1+1+1+4

5) 1+2+2+2

6) 1+2+4

Help FJ count all possible representations for a given integer N (1 <= N <= 1,000,000).

 

[align=left]Input[/align]
A single line with a single integer, N.
 

[align=left]Output[/align]
The number of ways to represent N as the indicated sum. Due to the potential huge size of this number, print only last 9 digits (in base 10 representation).
 

[align=left]Sample Input[/align]

7

 

[align=left]Sample Output[/align]

6
dp
=dp[n-1]+dp[n-2]+dp[n-4]+dp[n-8].....防止重复的方法是 假设2最大来一次 4 最大来一....#include<iostream>
#include<cstring>
#define N 1000005
using namespace std;
long long dp
={0};
long long c[25]={0};
int main()
{
int n=0;
c[0]=1;
int t=0;
for(t=1;t<=24;t++)
{
c[t]=c[t-1]*2;
}
dp[0]=1;
for(int i=0;i<24&&c[i]<=N;i++)
      {
    for(int j=c[i];j<=N;j++)
    {
    dp[j]=(dp[j]+dp[j-c[i]])%1000000000;
}
 }
while(scanf("%d",&n)!=EOF)
{
 printf("%lld\n",dp
);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: