您的位置:首页 > 其它

hdu 1150 Machine Schedule(最小顶点覆盖)

2015-12-13 11:46 253 查看


Machine Schedule

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 5424 Accepted Submission(s): 2691



Problem Description

As we all know, machine scheduling is a very classical problem in computer science and has been studied for a very long history. Scheduling problems differ widely in the nature of the constraints that must be satisfied and the type of schedule desired. Here
we consider a 2-machine scheduling problem.

There are two machines A and B. Machine A has n kinds of working modes, which is called mode_0, mode_1, …, mode_n-1, likewise machine B has m kinds of working modes, mode_0, mode_1, … , mode_m-1. At the beginning they are both work at mode_0.

For k jobs given, each of them can be processed in either one of the two machines in particular mode. For example, job 0 can either be processed in machine A at mode_3 or in machine B at mode_4, job 1 can either be processed in machine A at mode_2 or in machine
B at mode_4, and so on. Thus, for job i, the constraint can be represent as a triple (i, x, y), which means it can be processed either in machine A at mode_x, or in machine B at mode_y.

Obviously, to accomplish all the jobs, we need to change the machine's working mode from time to time, but unfortunately, the machine's working mode can only be changed by restarting it manually. By changing the sequence of the jobs and assigning each job to
a suitable machine, please write a program to minimize the times of restarting machines.

Input

The input file for this program consists of several configurations. The first line of one configuration contains three positive integers: n, m (n, m < 100) and k (k < 1000). The following k lines give the constrains of the k jobs, each line is a triple: i,
x, y.

The input will be terminated by a line containing a single zero.

Output

The output should be one integer per line, which means the minimal times of restarting machine.

Sample Input

5 5 10
0 1 1
1 1 2
2 1 3
3 1 4
4 2 1
5 2 2
6 2 3
7 2 4
8 3 3
9 4 3
0


Sample Output

3


题意:有A、B两个机器。每一个机器有多个状态,每一个状态能够完毕某项工作。求完毕一些工作所需的最少状态。

最小顶点覆盖:包括二分图的X,Y部的部分顶点的一个集合,使得全部的边至少有一个顶点在该点集内。

最小顶点覆盖 = 二分图的最大匹配

#include"stdio.h"
#include"string.h"
#define N 105
int g

;
int link
,mark
,n,m;
int find(int k)
{
int i;
for(i=1;i<m;i++)
{
if(!mark[i]&&g[k][i])
{
mark[i]=1;
if(!link[i]||find(link[i]))
{
link[i]=k;
return 1;
}
}
}
return 0;
}
int main()
{
int i,a,b,c,k;
while(scanf("%d",&n),n)
{
memset(g,0,sizeof(g));
memset(link,0,sizeof(link));
scanf("%d%d",&m,&k);
while(k--)
{
scanf("%d%d%d",&c,&a,&b);
if(a&&b)             //起始状态不需转换
{
g[a][b]=1;
}
}
int ans=0;
for(i=1;i<n;i++)
{
memset(mark,0,sizeof(mark));
ans+=find(i);
}
printf("%d\n",ans);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: