您的位置:首页 > 其它

杭电2592Counting Sheep dfs+bfs

2015-12-12 19:26 267 查看


Counting Sheep

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 2669    Accepted Submission(s): 1772


Problem Description

A while ago I had trouble sleeping. I used to lie awake, staring at the ceiling, for hours and hours. Then one day my grandmother suggested I tried counting sheep after I'd gone to bed. As always when my grandmother suggests things, I decided to try it out.
The only problem was, there were no sheep around to be counted when I went to bed.



Creative as I am, that wasn't going to stop me. I sat down and wrote a computer program that made a grid of characters, where # represents a sheep, while . is grass (or whatever you like, just not sheep). To make the counting a little more interesting, I also
decided I wanted to count flocks of sheep instead of single sheep. Two sheep are in the same flock if they share a common side (up, down, right or left). Also, if sheep A is in the same flock as sheep B, and sheep B is in the same flock as sheep C, then sheeps
A and C are in the same flock.

Now, I've got a new problem. Though counting these sheep actually helps me fall asleep, I find that it is extremely boring. To solve this, I've decided I need another computer program that does the counting for me. Then I'll be able to just start both these
programs before I go to bed, and I'll sleep tight until the morning without any disturbances. I need you to write this program for me.

 

Input

The first line of input contains a single number T, the number of test cases to follow.

Each test case begins with a line containing two numbers, H and W, the height and width of the sheep grid. Then follows H lines, each containing W characters (either # or .), describing that part of the grid.

 

Output

For each test case, output a line containing a single number, the amount of sheep flock son that grid according to the rules stated in the problem description.

Notes and Constraints

0 < T <= 100

0 < H,W <= 100

 

Sample Input

2
4 4
#.#.
.#.#
#.##
.#.#
3 5
###.#
..#..
#.###

 

Sample Output

6
3

 

Source

IDI Open 2009

 

Recommend

gaojie   |   We have carefully selected several similar problems for you:  1426 1067 1175 3368 1035 

 

水题,附dfs+bfs:

dfs:

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
char map[110][110];
int dx[]={1,0,0,-1};
int dy[]={0,1,-1,0};
int i,j,k,l,m,n,num;
void dfs(int x,int y)
{
int i=0;
if(x<0||x>=m||y<0||y>=n)
return ;
if(map[x][y]=='.')
return ;
//num+=1;
map[x][y]='.';
for(i=0;i<4;i++)
dfs(x+dx[i],y+dy[i]);
return ;
}
int main()
{
scanf("%d",&k);
while(k--)
{
num=0;
scanf("%d%d",&m,&n);
for(i=0;i<m;i++)
scanf("%s",map[i]);
for(i=0;i<m;i++)
for(j=0;j<n;j++)
{
if(map[i][j]=='#')
{
num++;
dfs(i,j);
}
}
printf("%d\n",num);
}
}bfs:
#include<string.h>
#include<stdio.h>
#include<iostream>
#include<queue>
#include<algorithm>
using namespace std;
struct node
{
int x;
int y;
}start,p,flag;
int i,j,k,l,m,n;
char map[110][110];
int judge(int x,int y)
{
if(x<0||x>=m||y<0||y>=n)
return 0;
if(map[x][y]=='.')
return 0;
return 1;
}
int dx[]={1,0,0,-1};
int dy[]={0,1,-1,0};
void bfs()
{

queue<node > q;
q.push(start);
map[start.x][start.y]='.';
while(!q.empty())
{
p=q.front();
q.pop();
for(int i=0;i<4;i++)
{
flag.x =p.x + dx[i];
flag.y =p.y + dy[i];
if(judge(flag.x,flag.y))
{
q.push(flag);
map[flag.x][flag.y]='.';
}

}
}
}
int main()
{
scanf("%d",&k);
while(k--)
{
scanf("%d%d",&m,&n);
for(i=0;i<m;i++)
scanf("%s",map[i]);
int num=0;
for(i=0;i<m;i++)
for(j=0;j<n;j++)
{
if(map[i][j]=='#')
{
num++;
start.x =i;
start.y =j;
bfs();
}
}
printf("%d\n",num);
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  bfs dfs 杭电 搜索 简单题