您的位置:首页 > 其它

01背包问题

2015-12-12 13:10 302 查看

Bone Collector

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 42663 Accepted Submission(s): 17765

Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …

The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the
maximum of the total value the bone collector can get ?

[align=left]Input[/align]
The first line contain a integer T , the number of cases.

Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third
line contain N integers representing the volume of each bone.
[align=left]Output[/align]
One integer per line representing the maximum of the total value (this number will be less than 231).
[align=left]Sample Input[/align]

1
5 10
1 2 3 4 5
5 4 3 2 1


[align=left]Sample Output[/align]

14


题目大意:先给定骨头数量N和背包容量V,

下面一行代表每个骨头的价值value,

再下面一行代表骨头对应的容量,求不超过背包容量V,能装入骨头的最大价值

原题地址:http://acm.hdu.edu.cn/showproblem.php?pid=2602

实现代码:

import java.util.Scanner;
public class Main{
public static void main(String[] args) {
Scanner cin=new Scanner(System.in);
int  casenum=cin.nextInt();
int boneNum=0;
int packVolume=0;
int  result[]=new int [casenum];
while (casenum-->0) {
boneNum=cin.nextInt();
packVolume=cin.nextInt();//总背包容量
            int value[]=new int[boneNum+1];
int volume[]=new int[boneNum+1];
for (int i = 1; i < boneNum+1; i++) {//初始化价值
value[i]=cin.nextInt();
}
for (int i = 1; i < boneNum+1; i++) {//初始化容量
volume[i]=cin.nextInt();
}
result[casenum]=dp(boneNum,packVolume,value,volume);
}

for (int i = result.length-1; i >=0; ) {
System.out.println(result[i--]);
}
}
private static int dp(int boneNum, int packVolume, int[] value,
int[] volume) {
int  d[][]=new int[boneNum+1][packVolume+1];
for (int i = 1; i < boneNum+1; i++) {
for (int j = 0; j<=packVolume; j++) {
if (j>=volume[i]) {
d[i][j]=Math.max(d[i-1][j], d[i-1][j-volume[i]]+value[i]);
}

else/* if(j<volume[i])*/{
d[i][j]=d[i-1][j];
}
}
}
return d[boneNum][packVolume] ;

}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: