您的位置:首页 > 其它

HDU1251 统计难题 字典树裸题

2015-12-11 17:05 344 查看

HDU1251 统计难题

Time Limit:2000MS Memory Limit:65535KB 64bit IO Format:%I64d & %I64u

Submit

Status

Practice

Description

Ignatius最近遇到一个难题,老师交给他很多单词(只有小写字母组成,不会有重复的单词出现),现在老师要他统计出以某个字符串为前缀的单词数量(单词本身也是自己的前缀).

Input

输入数据的第一部分是一张单词表,每行一个单词,单词的长度不超过10,它们代表的是老师交给Ignatius统计的单词,一个空行代表单词表的结束.第二部分是一连串的提问,每行一个提问,每个提问都是一个字符串.

注意:本题只有一组测试数据,处理到文件结束.

Output

对于每个提问,给出以该字符串为前缀的单词的数量.

Sample Input

banana

band

bee

absolute

acm

ba

b

band

abc

Sample Output

2

3

1

0

题解:

敲个字典树即可

代码

#include<iostream>
#include<cstdio>
#include<string>
#include<cstring>
using namespace std;
const int maxn = 500002;
int Next[maxn][27];
int word[maxn];
struct Tree
{
int L,root;

void init()
{
L = 0;
root = newnode();
}

int newnode()
{
for (int i = 0;i<27;i++)
Next[L][i] = -1;
word[L++]=0;
return L-1;
}

void insert(char *s)
{
int u = root;
int l = strlen(s);
for (int i = 0;i<l;i++)
{
int c = s[i] - 'a';
if (Next[u][c] == -1)
Next[u][c] = newnode();
u = Next[u][c];
word[u]++;
}
}

int query(char *s)
{
int u = root;
int l = strlen(s);
for (int i = 0;i<l;i++)
{
int c = s[i] - 'a';
if (Next[u][c] == -1)
return 0;
u=Next[u][c];
}
return word[u];
}
};
int main()
{
Tree tree;
tree.init();
char str[1001];
while (gets(str))
{
if (!strcmp(str,""))
break;
tree.insert(str);
}
char s[1001];
while (scanf("%s",s)!=EOF)
{
int count = tree.query(s);
printf("%d\n",count);
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: