您的位置:首页 > 产品设计 > UI/UE

HDOJ 题目4296 Buildings(贪心)

2015-12-09 12:00 489 查看

Buildings

Time Limit: 5000/2000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 3006 Accepted Submission(s): 1141



[align=left]Problem Description[/align]
  Have you ever heard the story of Blue.Mary, the great civil engineer? Unlike Mr. Wolowitz, Dr. Blue.Mary has accomplished many great projects, one of which is the Guanghua Building.

  The public opinion is that Guanghua Building is nothing more than one of hundreds of modern skyscrapers recently built in Shanghai, and sadly, they are all wrong. Blue.Mary the great civil engineer had try a completely new evolutionary building method in
project of Guanghua Building. That is, to build all the floors at first, then stack them up forming a complete building.

  Believe it or not, he did it (in secret manner). Now you are face the same problem Blue.Mary once stuck in: Place floors in a good way.

  Each floor has its own weight wi and strength si. When floors are stacked up, each floor has PDV(Potential Damage Value) equal to (Σwj)-si, where (Σwj) stands for sum of weight of all floors above.

  Blue.Mary, the great civil engineer, would like to minimize PDV of the whole building, denoted as the largest PDV of all floors.

  Now, it’s up to you to calculate this value.

[align=left]Input[/align]
  There’re several test cases.

  In each test case, in the first line is a single integer N (1 <= N <= 105) denoting the number of building’s floors. The following N lines specify the floors. Each of them contains two integers wi and si (0 <= wi,
si <= 100000) separated by single spaces.

  Please process until EOF (End Of File).

[align=left]Output[/align]
  For each test case, your program should output a single integer in a single line - the minimal PDV of the whole building.

  If no floor would be damaged in a optimal configuration (that is, minimal PDV is non-positive) you should output 0.

[align=left]Sample Input[/align]

3
10 6
2 3
5 4
2
2 2
2 2
3
10 3
2 5
3 3


[align=left]Sample Output[/align]

1
0
2


[align=left]Source[/align]
2012 ACM/ICPC Asia Regional Chengdu Online

[align=left]Recommend[/align]
liuyiding | We have carefully selected several similar problems for you: 4295 4294 4293 4292 4291
有n个楼层,每个楼层有一重量w,一个宽度s,每个楼层的损坏值,是他上边的楼层w的和减去他的s,,问你你叠放的最小的楼层损坏值是多少,,,
我特喵读的是楼层的最小的·和,wa了好多次。。。
实际上·还是蛮简单的,a放b上的损坏值b的是a.w-b.s,b放a上a的损坏值b.w-a.s,a.w-b.s<b.w-a.s排就好。。
ac代码
#include<string.h>
#include<stdlib.h>
#include<algorithm>
#include<iostream>
#include<stdio.h>
#define LL long long
using namespace std;
struct S
{
LL w,s;
}b[100550];
int cmp(S a, S b)
{
return a.w+a.s>b.w+b.s;
}
LL sum[100550];
int main()
{
int n;
while(scanf("%d",&n)!=EOF)
{
int i,j;
for(i=1;i<=n;i++)
{
scanf("%lld%lld",&b[i].w,&b[i].s);
}
sort(b+1,b+n+1,cmp);
for(i=1;i<=n;i++)
{
sum[i]=sum[i-1]+b[i].w;
}
LL ans=0;
for(i=1;i<=n;i++)
{

LL temp=sum
-sum[i];
temp-=b[i].s;
if(temp<0)
temp=0;
ans=max(ans,temp);
}
printf("%lld\n",ans);
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: