您的位置:首页 > 其它

1016. Phone Bills (25)

2015-12-06 10:17 381 查看
时间限制400 ms
内存限制65536 kB
代码长度限制16000 B
判题程序Standard作者CHEN, Yue
去掉非法数据计算账单

A long-distance telephone company charges its customers by the following rules:

Making a long-distance call costs a certain amount per minute, depending on the time of day when the call is made. When a customer starts connecting a long-distance call, the time will be recorded, and so will be the time when the customer hangs up the phone. Every calendar month, a bill is sent to the customer for each minute called (at a rate determined by the time of day). Your job is to prepare the bills for each month, given a set of phone call records.

Input Specification:

Each input file contains one test case. Each case has two parts: the rate structure, and the phone call records.

The rate structure consists of a line with 24 non-negative integers denoting the toll (cents/minute) from 00:00 - 01:00, the toll from 01:00 - 02:00, and so on for each hour in the day.

The next line contains a positive number N (<= 1000), followed by N lines of records. Each phone call record consists of the name of the customer (string of up to 20 characters without space), the time and date (mm:dd:hh:mm), and the word "on-line" or "off-line".

For each test case, all dates will be within a single month. Each "on-line" record is paired with the chronologically next record for the same customer provided it is an "off-line" record. Any "on-line" records that are not paired with an "off-line" record are ignored, as are "off-line" records not paired with an "on-line" record. It is guaranteed that at least one call is well paired in the input. You may assume that no two records for the same customer have the same time. Times are recorded using a 24-hour clock.

Output Specification:

For each test case, you must print a phone bill for each customer.

Bills must be printed in alphabetical order of customers' names. For each customer, first print in a line the name of the customer and the month of the bill in the format shown by the sample. Then for each time period of a call, print in one line the beginning and ending time and date (dd:hh:mm), the lasting time (in minute) and the charge of the call. The calls must be listed in chronological order. Finally, print the total charge for the month in the format shown by the sample.

Sample Input:
10 10 10 10 10 10 20 20 20 15 15 15 15 15 15 15 20 30 20 15 15 10 10 10
10
CYLL 01:01:06:01 on-line
CYLL 01:28:16:05 off-line
CYJJ 01:01:07:00 off-line
CYLL 01:01:08:03 off-line
CYJJ 01:01:05:59 on-line
aaa 01:01:01:03 on-line
aaa 01:02:00:01 on-line
CYLL 01:28:15:41 on-line
aaa 01:05:02:24 on-line
aaa 01:04:23:59 off-line
Sample Output:
CYJJ 01
01:05:59 01:07:00 61 $12.10
Total amount: $12.10
CYLL 01
01:06:01 01:08:03 122 $24.40
28:15:41 28:16:05 24 $3.85
Total amount: $28.25
aaa 01
02:00:01 04:23:59 4318 $638.80
Total amount: $638.80

来源: <http://www.patest.cn/contests/pat-a-practise/1016>

#include<iostream>

#include<algorithm>

#include<vector>

#include<map>

#include<string>

#include<string.h>

#include<stdio.h>

#pragma warning(disable:4996)


using namespace std;


struct Record

{

char name[25];

char time[12];

char stat[9];

int timeTrans;

int statCode;  //0 means online ;1 means offline

};


struct People{

int startTime = -1;

int endTime = -1;

double amount = 0;

vector<int> startTimeList;

vector<int> endTimeList;

vector<double> feeList;

vector<int> callMinList;

};



vector<Record> r;

vector<string> nameList;

map < string, People > mp;

int month;

int feeRule[25] = { 0 };


bool cmp(Record a, Record b){

return a.timeTrans < b.timeTrans;

}


double CalcFee(int start, int end){

int fee = 0;

while (start<end)

{

fee += feeRule[start / 60 % 24];

start++;

}


return 1.0*fee/100;

}


int main(void){

//freopen("Text.txt", "r", stdin);


for (int i = 0; i < 24; i++){

cin >> feeRule[i];

}

int n;

cin >> n;

for (int i = 0; i < n; i++){

Record temp;

scanf("%s %s %s", temp.name, temp.time, temp.stat);

if (temp.stat[1] == 'n')

temp.statCode = 0;

else

temp.statCode = 1;

int td, th, tm, ttime;

sscanf(temp.time, "%d:%d:%d:%d", &month, &td, &th, &tm);

ttime = td * 1440 + th * 60 + tm;

temp.timeTrans = ttime;

r.push_back(temp);

}

sort(r.begin(), r.end(), cmp);


for (int i = 0; i < n; i++){

string nameStr;

int q = 0;

while (r[i].name[q]!=0)

	{

nameStr += r[i].name[q];

q++;

}

if (r[i].statCode == 0){//online

mp[nameStr].startTime = r[i].timeTrans;

}

else{

if (mp[nameStr].startTime == -1){

continue;

}

	else{

mp[nameStr].endTime = r[i].timeTrans;

mp[nameStr].startTimeList.push_back(mp[nameStr].startTime);

mp[nameStr].endTimeList.push_back(mp[nameStr].endTime);

mp[nameStr].feeList.push_back(CalcFee(mp[nameStr].startTime,mp[nameStr].endTime));

mp[nameStr].callMinList.push_back(mp[nameStr].endTime - mp[nameStr].startTime);

mp[nameStr].startTime = -1;

mp[nameStr].endTime = -1;

}

}

}


for (auto &k : mp){

nameList.push_back(k.first);

}


sort(nameList.begin(), nameList.end());


for (int i = 0; i < nameList.size(); i++){

if (mp[nameList[i]].startTimeList.size() == 0)

continue;

cout << nameList[i] << " ";

printf("%02d\n", month);

double totalFee = 0;

for (int j = 0; j < mp[nameList[i]].startTimeList.size(); j++){

int sd = mp[nameList[i]].startTimeList[j] / 1440;

int sh = mp[nameList[i]].startTimeList[j] / 60 % 24;

int sm = mp[nameList[i]].startTimeList[j] % 60;

int ed = mp[nameList[i]].endTimeList[j] / 1440;

int eh = mp[nameList[i]].endTimeList[j] / 60 % 24;

int em = mp[nameList[i]].endTimeList[j] % 60;

printf("%02d:%02d:%02d %02d:%02d:%02d %d $%.2f\n", sd, sh, sm, ed, eh, em, mp[nameList[i]].callMinList[j], mp[nameList[i]].feeList[j]);

totalFee += mp[nameList[i]].feeList[j];

}

printf("Total amount: $%.2f\n",totalFee);

}


return 0;

}

[/code]

来自为知笔记(Wiz)
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: