您的位置:首页 > 产品设计 > UI/UE

1041. Be Unique (20)【水题】——PAT (Advanced Level) Practise

2015-12-06 00:12 513 查看

题目信息

1041. Be Unique (20)

时间限制100 ms

内存限制65536 kB

代码长度限制16000 B

Being unique is so important to people on Mars that even their lottery is designed in a unique way. The rule of winning is simple: one bets on a number chosen from [1, 104]. The first one who bets on a unique number wins. For example, if there are 7 people betting on 5 31 5 88 67 88 17, then the second one who bets on 31 wins.

Input Specification:

Each input file contains one test case. Each case contains a line which begins with a positive integer N (<=10^5) and then followed by N bets. The numbers are separated by a space.

Output Specification:

For each test case, print the winning number in a line. If there is no winner, print “None” instead.

Sample Input 1:

7 5 31 5 88 67 88 17

Sample Output 1:

31

Sample Input 2:

5 888 666 666 888 888

Sample Output 2:

None

解题思路

记录每个数出现次数,第一个出现一次的为所求

AC代码

#include <cstdio>
#include <map>
#include <vector>
using namespace std;
int main()
{
int n, t;
vector<int> v;
map<int, int> mp;
scanf("%d", &n);
for (int i = 0; i < n; ++i){
scanf("%d", &t);
v.push_back(t);
mp[t]++;
}
bool flag = false;
for (int i = 0; i < v.size(); ++i){
if (mp[v[i]] == 1){
printf("%d\n", v[i]);
flag = true;
break;
}
}
if (!flag){
printf("None\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  pat 1041